Social Buttons
Results 1 to 6 of 6

Thread: Kenmore gas range - oven burners won't light

  1. #1
    Join Date
    Sep 2005
    Location
    Detroit
    Posts
    9

    Default Kenmore gas range - oven burners won't light

    I have a Kenmore gas range/oven, approximately 7 years old. Unfortunately I don't have a model number with me right now. We recently moved to a different house and when we hooked it up after moving it, the burners in the oven won't light. The burners on the stove top ignite sometimes, but other times I have to light them with a lighter (about a 50/50 chance that I have to light them manually).

    When I turn the oven on to preheat or bake, it clicks like it normally would when it was working properly at the other house. I removed the panel from the oven floor to take a look, and the ignitor glows red, the burners just won't ignite. I don't smell gas at all in the oven when those burners don't ignite, but I DO if the stove top burners don't.

    The only thing different between the two houses is that the supply line at the old house was 3/4" and the supply line at the new house is 1/2".

    Any suggestions for now? I'll look for the part number this evening.

  2. #2
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,856

    Default

    Hi,

    We would need the model# of your range.

    If the oven igniter glow bar is glowing red and the gas doesn't start coming out after 2 minutes, thats usually a sign of a bad/weak glow bar.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  3. #3
    Join Date
    Sep 2005
    Location
    Detroit
    Posts
    9

    Default

    This thread should be moved to the Kitchenaid forum...my mistake, sorry mods!

    The model number is FGF374CCSB.

  4. #4
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,856

    Default

    Sorry for the delay, its been very busy.

    That model# you posted is a Frigidaire.

    Is that what you have?

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  5. #5
    Join Date
    Jan 2012
    Location
    Johnstown, Pennsylvania, United States
    Posts
    2

    Default

    ok jake a frididaire model fgf374ccsb wads used as a propaine stove we need it to work on natural gas what do we need to do? it was given to a friend of mine and we are trying to get it working with out haveing to pay 75+dollars for a repairman i know i had a stove it was just closeing a few air ports and it would work

  6. #6
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,856

    Default

    You will need to order the original orifices if the original owner didn't save them when it was converted from Natural to LP.

    Here's the original ones you can order(order 3 for the small burners):
    Orifice 5303210090 Order now for same day shipping. 365 day return policy. RepairClinic.com

    And 1 for the large burner:
    Orifice 316010804 Order now for same day shipping. 365 day return policy. RepairClinic.com

    You will then need to turn the plastic piece over in your gas regulator as seen here:
    http://www.applianceaid.com/newpics/frigconversion2.JPG

    And also the burner spud on the oven valve as seen here:
    http://www.applianceaid.com/newpics/frigconversion4.JPG

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

Similar Threads

  1. Kenmore gas oven slow to heat up
    By t7044wa in forum Sears Kenmore
    Replies: 5
    Last Post: November 6th, 2007, 05:43 PM
  2. Simple Kenmore range: burners won't turn on, light does
    By thinkmassive in forum Sears Kenmore
    Replies: 5
    Last Post: August 3rd, 2007, 10:46 AM
  3. Replies: 2
    Last Post: April 11th, 2007, 08:53 AM
  4. Year Old Kenmore Gas Oven Won't Light
    By maggie2853 in forum Sears Kenmore
    Replies: 3
    Last Post: March 15th, 2007, 03:27 PM
  5. Kenmore gas oven 362.72295790 oven won't light
    By bandit1trucking in forum Sears Kenmore
    Replies: 1
    Last Post: November 20th, 2006, 01:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog