Results 1 to 2 of 2

Thread: ultrawave microwave hood - no power

  1. #1
    Join Date
    Nov 2007
    Location
    Wallingford, PA
    Posts
    1

    Default ultrawave microwave hood - no power

    MOdel: 665.61654

    Made popcorn in microwave last night and everything seemed to work fine. Woke up this morning and there were no lights and none of the buttons worked. I checked circuit breaker and it was ok and then checked jack and it showed it was getting juice. Any ideas what the problem might be? Is there any kind of circuit breaker or fuse in the unit? Got nothing! what might have burned out?

  2. #2
    Join Date
    Aug 2006
    Location
    New York
    Posts
    10

    Default

    Check for the internal fuse within the Microwave. or you can check the resistance across the power cord between the two hot wire if it is opened then the fuse is likely the culprit

Similar Threads

  1. KitchenAid Microwave Hood Combo #KHMS155L
    By feelingrippedoff in forum Whirlpool/KitchenAid
    Replies: 2
    Last Post: September 25th, 2011, 05:46 PM
  2. Kenmore Microwave hood 721.80602500
    By Jack1 in forum Sears Kenmore
    Replies: 0
    Last Post: September 1st, 2007, 10:01 PM
  3. Microwave Using Tips
    By nancypeterson in forum Microwaves
    Replies: 0
    Last Post: July 30th, 2007, 05:31 AM
  4. maytag msd2756de no power to ice-water panel
    By frigcon in forum Maytag/Magic Chef/Admiral/Jenn-Air
    Replies: 3
    Last Post: November 8th, 2006, 11:40 AM
  5. kenmore ultrawave microwave hood
    By flabbb in forum Sears Kenmore
    Replies: 3
    Last Post: March 29th, 2006, 12:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog