Social Buttons
Results 1 to 10 of 10

Thread: PLDB998CC0 - Clicking & Flashing

  1. #1
    Join Date
    Jun 2008
    Location
    Liberty Township, OH
    Posts
    5

    Default PLDB998CC0 - Clicking & Flashing

    Model Number: PLDB998CC0
    Brand: Frigidaire
    Age: 1-5 years

    Professional Series 900. Approximately 5 years old. Appears to work normally for about half the cycle and then starts making loud clicking noises that correspond with the time flashing in the status window. It continues to run but seems "stuck". If I cancel the cycle the dishwasher will drain normally.

    Control board?

  2. #2
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,538

    Default

    Yup,

    You'll need a new control board.

    Here's the one for your model you can order: Frigidaire 154445803 Control,electronic - AppliancePartsPros.com

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  3. #3
    Join Date
    Jun 2008
    Location
    Liberty Township, OH
    Posts
    5

    Default

    Ok. Thanks for you help!

  4. #4
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,538

    Default

    Glad to help, let us know the outcome.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  5. #5
    Join Date
    Jun 2008
    Location
    Liberty Township, OH
    Posts
    5

    Default New Control Board - Connector mis-match

    Okay. I got the new control board, but there is a slight mis-match on one of the connectors. See photos.

    Old Board:

    Click image for larger version. 

Name:	IMG_4099.JPG 
Views:	172 
Size:	64.2 KB 
ID:	896

    New Board:

    Click image for larger version. 

Name:	IMG_4100.JPG 
Views:	172 
Size:	49.5 KB 
ID:	897

    Connector:

    Click image for larger version. 

Name:	IMG_4101.JPG 
Views:	173 
Size:	60.5 KB 
ID:	898

    Do I have the wrong board, or is there another solution?

  6. #6
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,538

    Default

    Yea, I see what you mean.

    Thats odd, because the photo of that board in the link I posted above shows to be the same identical connector as your old board.

    Is there a part# on the new board you got?

    It should read Part Number: 154445803

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  7. #7
    Join Date
    Jun 2008
    Location
    Liberty Township, OH
    Posts
    5

    Default

    Label on board reads as follows:

    SPITFIRE CONTROLS
    SF2001-009A REV F
    Part No: 154362809

  8. #8
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,538

    Default

    Thats the wrong board. You'll need to send it back for the correct one.

    They will pay for shipping since it was their error:
    https://www.appliancepartspros.com/a...t/returns.aspx

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  9. #9
    Join Date
    Jun 2008
    Location
    Liberty Township, OH
    Posts
    5

    Default Thanks!

    I put the correct conrol board in last week and everything is back to normal. Thanks for the help.

  10. #10
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,538

    Default

    Excellent, good job, glad its back to normal again.

    Thanks for the update.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

Similar Threads

  1. Front control panel clicking, lights flashing, not working....
    By Frustrated in forum Frigidaire/Electrolux
    Replies: 2
    Last Post: June 11th, 2012, 04:24 PM
  2. Frigidaire DW clicking and flashing during full wash cycle only
    By gbrackenridge in forum Frigidaire/Electrolux
    Replies: 3
    Last Post: March 24th, 2011, 10:03 AM
  3. Frigidaire Dishwasher PLDB998CC0 Won't Drain
    By arby in forum Frigidaire/Electrolux
    Replies: 3
    Last Post: May 7th, 2010, 09:39 AM
  4. PLDB998CC0 Won't drain
    By John Scholz in forum Frigidaire/Electrolux
    Replies: 3
    Last Post: April 6th, 2007, 11:01 AM
  5. PLDB998CC0 : Lights are are, but no one's washing
    By blues4orce in forum Frigidaire/Electrolux
    Replies: 3
    Last Post: March 28th, 2007, 11:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog