Results 1 to 8 of 8

Thread: Kenmore Elite 110.85876400 - Dead Front Panel ?

  1. #1
    Join Date
    Jul 2008
    Location
    Texas
    Posts
    7

    Default Kenmore Elite 110.85876400 - Dead Front Panel ?

    Hi,

    Kenmore Elite Model# 110.85876400 (HE4, Electric, Smartheat, made by Whirlpool)

    Here is my problem (just started out of the blue one day)
    The front control panel (with all the buttons for settings) is totally dead --

    Normally, numerous red lights come on when pressing buttons -- now its nothing when I hit the buttons.
    The lightbulb inside the drum is working fine when I open the door (and goes out when I close it, like usual).

    I've checked my house breakers (2 of them) and both are OK. I even turned them on and off a couple of times.

    This unit is only about 2 yrs old - just old enough to be out of warranty

    Any ideas on how to troubleshoot ? I can't even figure out how to open the panel - its the newer dryer with the circular opening (front load) -- the panel seems to be flush with the body and no obvious screws etc to open it to see anything.

    Any help is appreciated!

    thanks.

  2. #2
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    68,810

    Default

    Hi,

    Here is the online repair manual for the Kenmore HE4/Duet dryer:
    https://secured.whirlpool.com/Servic...LE/Duetdry.pdf
    Give it time to download.

    I'm attaching the simplified diagnostics sheet below(Page 10 tells how to take the bottom panel off):

    Page 8 has the button & LED test.

    Jake
    Attached Files Attached Files
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  3. #3
    Join Date
    Jul 2008
    Location
    Texas
    Posts
    7

    Default

    Jake:

    Thanks for the links. I'll open up the dryer today and see what I can find based on the docs you posted.

    I'll post here the results or if I run into trouble with anything while trying to do it !!

  4. #4
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    68,810

    Default

    Sounds good, let us know what happens.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  5. #5
    Join Date
    Jul 2008
    Location
    Texas
    Posts
    7

    Default Initial testing results ....

    Jake,

    I tested based on the diagnostics sheet (pg 8) -- about half of the buttons did not generate a reading on my multi-meter - the other half did show some reading when pressed.

    I assumed the black wire was position "1" (in the 1-14 pins).

    Does that mean the console/button board needs replacement? Is it common for some buttons to respond to the test, while others dont ?

    Just want to be sure I was measuring it correctly.

    Thanks

  6. #6
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    68,810

    Default

    Yes, it sounds like you'll need to replace your control panel assembly.

    Here's the control panel for your model:
    Whirlpool 280087 Cntrl-Elec - AppliancePartsPros.com


    The repair manual I posted a link to above shows you how to replace it.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  7. #7
    Join Date
    Jul 2008
    Location
    Texas
    Posts
    7

    Default

    Jake,

    Thanks for the link.

    Also I tested it using the exposed wire on the side of the cable connector (not on the end - the part that plugs in) -- would that make a difference ?
    (my probe lead was too thick to go into the actual "holes" on the pin)

    Does this site have any warranty for the part ? Is this part prone to failure?

    thanks

  8. #8
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    68,810

    Default

    Yes, the way you tested it was fine.

    It comes with a special 365 day full refund if you install it and it doesn't fix the problem.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

Similar Threads

  1. Kenmore Elite HE3T ( 110.42926200 ) dead
    By Shockdaddyd in forum Sears Kenmore
    Replies: 2
    Last Post: June 25th, 2007, 10:48 AM
  2. Kenmore Calypso 110.22082102 front panel is dead
    By abes1 in forum Sears Kenmore
    Replies: 1
    Last Post: December 5th, 2006, 11:02 PM
  3. Kenmore Elite 665.17462300 keypad panel
    By rleist in forum Sears Kenmore
    Replies: 3
    Last Post: September 7th, 2006, 12:07 PM
  4. Kenmore Elite 110.63932101 Back Panel Off?
    By jbell44 in forum Sears Kenmore
    Replies: 1
    Last Post: August 24th, 2005, 09:41 PM
  5. Dead Kenmore Elite dryer
    By dbhovel in forum Sears Kenmore
    Replies: 6
    Last Post: December 16th, 2004, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog