Social Buttons
Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Kenmore 790.9661 Oven Elements Don't Heat

  1. #1
    Join Date
    Jul 2008
    Location
    Rhode Island
    Posts
    4

    Default Kenmore 790.9661 Oven Elements Don't Heat

    Hi,

    I've searched this forum for tips and answers and am asking for confirmation concerning my situation:

    1. Kenmore 790.96614400 Electric Range 4 years old
    2. The range is receiving 240 volts at the power terminal strip
    3. Everything but the oven elements work fine
    4. No error codes
    5. Broiler element measures 14 ohms and 32 volts across the terminals
    6. Oven element measure 17 ohms and 35 volts across the terminals

    From what I've read, this sounds like the Electronic Oven Control (EOC) unit.

    If that's correct, where can I buy a replacement and at what cost.

    Thanks for your help.

    Michael
    Last edited by AugustLeo; July 21st, 2008 at 11:44 AM.

  2. #2
    Join Date
    Mar 2008
    Location
    Louisville,Ms
    Posts
    21

    Default

    Hi, I've got the same problem with a Kenmore #790.96011401. Bake unit went out, burned really bad, and the owner installed new element. Range will work on broil, but not bake. No fault codes, no 240 volts to bake element. Everything else works. I'm thinking EOC. Any other ideas? Thanks.

  3. #3
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,362

    Default

    Quote Originally Posted by AugustLeo View Post
    Hi,

    I've searched this forum for tips and answers and am asking for confirmation concerning my situation:

    1. Kenmore 790.96614400 Electric Range 4 years old
    2. The range is receiving 240 volts at the power terminal strip
    3. Everything but the oven elements work fine
    4. No error codes
    5. Broiler element measures 14 ohms and 32 volts across the terminals
    6. Oven element measure 17 ohms and 35 volts across the terminals

    From what I've read, this sounds like the Electronic Oven Control (EOC) unit.

    If that's correct, where can I buy a replacement and at what cost.

    Thanks for your help.

    Michael
    Hi Michael,

    Yes, your broil & bake elements ohm out fine, so its likely your EOC.

    Here's the cheapest one I found for your model thats in stock that you can order:
    Manufacturer's Number: 316418702
    icon

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  4. #4
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,362

    Default

    Quote Originally Posted by shadowrider View Post
    Hi, I've got the same problem with a Kenmore #790.96011401. Bake unit went out, burned really bad, and the owner installed new element. Range will work on broil, but not bake. No fault codes, no 240 volts to bake element. Everything else works. I'm thinking EOC. Any other ideas? Thanks.
    Hi shadowrider, your model uses a different EOC part# than Michael's.

    Here's the cheapest one I found for your model thats in stock you can order:
    Manufacturer's Number: 316418208


    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  5. #5
    Join Date
    Jul 2008
    Location
    Rhode Island
    Posts
    4

    Default

    Thanks Jake.

    I ordered the part you recommended. I believe it is returnable if it doesn't fix the problem (is that true?)

    I'll let you know how it turns out and thanks again.

    Michael

  6. #6
    Join Date
    Mar 2008
    Location
    Louisville,Ms
    Posts
    21

    Default

    Thanks Jake, I'll check with my customer and see what he wants to do.

  7. #7
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,362

    Default

    Quote Originally Posted by AugustLeo View Post
    Thanks Jake.

    I ordered the part you recommended. I believe it is returnable if it doesn't fix the problem (is that true?)

    I'll let you know how it turns out and thanks again.

    Michael
    Yup Michael, you have a full 30 day full refund if it doesn't fix the problem and you need to return it.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  8. #8
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,362

    Default

    Quote Originally Posted by shadowrider View Post
    Thanks Jake, I'll check with my customer and see what he wants to do.
    Sounds good shadowrider.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  9. #9
    Join Date
    Jul 2008
    Location
    Rhode Island
    Posts
    4

    Default

    Quote Originally Posted by Jake View Post
    Yup Michael, you have a full 30 day full refund if it doesn't fix the problem and you need to return it.

    Jake
    Works great, Jake. Easy to install too. Thanks again!

  10. #10
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,362

    Default

    Excellent, good job fixing it Michael.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 7
    Last Post: May 14th, 2011, 09:37 AM
  2. Kenmore 790.95683302 - oven doesn't heat up
    By pkcom in forum Sears Kenmore
    Replies: 3
    Last Post: March 14th, 2008, 10:45 AM
  3. Kenmore Oven Won't Heat
    By bd7 in forum Sears Kenmore
    Replies: 8
    Last Post: November 12th, 2007, 11:52 PM
  4. Kenmore gas oven slow to heat up
    By t7044wa in forum Sears Kenmore
    Replies: 5
    Last Post: November 6th, 2007, 05:43 PM
  5. Kenmore 911.93261690 oven won't heat
    By duaned53172 in forum Sears Kenmore
    Replies: 2
    Last Post: September 26th, 2006, 11:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog