Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [FIXED] Kenmore Series 80 doesn't fill - 110.27822790

  1. #1
    Join Date
    Jul 2008
    Location
    Morristown, NJ
    Posts
    6

    Default [FIXED] Kenmore Series 80 doesn't fill - 110.27822790

    At first it was intermittent, and just fiddling with the knobs a few times would get it to fill. Now, it doesn't fill at all. In fact, it starts agitating right away. I assume this means that there is something wrong with the water level sensor? Any suggestions are appreciated.

    Thanks!
    Last edited by mikesixtysix; July 27th, 2008 at 09:30 PM.

  2. #2
    Join Date
    Jul 2008
    Location
    Morristown, NJ
    Posts
    6

    Default

    Took the cabinet off, but not sure what I'm looking at... I see a clear tube right side in the back (if looking at the unit from the front)... hmm. a little help?

  3. #3
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    67,185

    Default

    Hi,

    When you move your water level knob to reset does it start filling with water?

    If so, then the problem is in your water level switch, here's the cheapest one I found for your model:
    Manufacturer's Number: 3366847
    icon
    icon
    icon3366847


    Jake

  4. #4
    Join Date
    Jul 2008
    Location
    Morristown, NJ
    Posts
    6

    Default

    Adjusting the water level knob has no effect, it won't fill no matter what settings are selected. It immediately starts agitating when it's turned on.

    What is the part that actually detects the water level? Perhaps that's what has gone bad...
    Last edited by mikesixtysix; July 28th, 2008 at 09:56 AM.

  5. #5
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    67,185

    Default

    The part I linked to above is your water level switch that tells it to put water in then start agitating. But I've also seen the timer do this as well.

    Take the clear rubber tube off the water level pressure switch and blow through the nipple on the water level pressure switch and you should hear it click. If no click sound then thats the problem, your water level switch. Then you can order a new one from that link above.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  6. #6
    Join Date
    Jul 2008
    Location
    Morristown, NJ
    Posts
    6

    Default

    I heard something, but definitely not a click. I'm going to replace this part... I'll let you know how it goes.

    Thanks!

  7. #7
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    67,185

    Default

    Ok, sounds good, yes, let us know how it goes.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  8. #8
    Join Date
    Jul 2008
    Location
    Morristown, NJ
    Posts
    6

    Default

    It worked! Awesome! Thanks Jake, you are the man!

  9. #9
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    67,185

    Default

    Excellent Mike, good job fixing it.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  10. #10
    Join Date
    Jul 2008
    Location
    Morristown, NJ
    Posts
    6

    Default

    the wife was saying, "just buy a new one"... but i'm glad i checked here first. i don't think they make them like they used to anymore, hopefully i'll get some more good years out of this old girl.

    thanks jake

Page 1 of 2 12 LastLast

Similar Threads

  1. Kenmore 70 Series leaks during fill
    By cogo162 in forum Sears Kenmore
    Replies: 3
    Last Post: March 19th, 2008, 11:22 AM
  2. Replies: 0
    Last Post: November 5th, 2007, 09:11 AM
  3. Kenmore 70 Series - tub won't fill
    By mbckmyr in forum Washers
    Replies: 1
    Last Post: April 1st, 2007, 12:12 PM
  4. Kenmore 70 series 11022722100 doesn't fill
    By mike56p in forum Sears Kenmore
    Replies: 3
    Last Post: January 1st, 2007, 09:32 PM
  5. Kenmore 80 series won't fill...
    By thegreatoz in forum Sears Kenmore
    Replies: 1
    Last Post: August 27th, 2005, 08:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog