Results 1 to 5 of 5

Thread: Kirkland Signature Whirlpool Refrigerator

  1. #1
    Join Date
    Feb 2005
    Location
    , ,
    Posts
    1

    Post imported post

    I have had (for the past 3 yrs) a Kirkland Signature (COSTCO Company) Whirlpool refrigerator....freezer on top; cooler below. It worked fine for the first year but now needs to be defrosted once a month. Ice builds up at the bottom of the freezer and clogs the water drainage hole at the rear/bottom of the freezer compartment. The ice build up also stops the flow of cold air downward into the refrigerator section of the unit. Then it starts leaking water (probably evaporation by-product). I have replaced the theromostat unit attached to the cooling coils in the freezer section and have had no positive results. Any suggestions? This Frig has been a real dog....:?

  2. #2
    Join Date
    Oct 2004
    Location
    Ontario, Canada
    Posts
    13,610

    Post imported post

    Hi,

    **Ice builds up at the bottom of the freezer and clogs the water drainage hole at the rear/bottom of the freezer compartment.**

    Ice like an ice cube or frost like snow?

    If clear ice, the defrost drain system is likely clogged/restricted and the defrost water is not running away. The drain system would need to be cleaned/flushed out.

    **Kirkland Signature (COSTCO Company) Whirlpool refrigerator**

    Model#? These are just names.

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

  3. #3
    Join Date
    Oct 2004
    Location
    Canada
    Posts
    578

    Post imported post

    jimmyg wrote:
    Whirlpool refrigerator... Ice builds up at the bottom of the freezer and clogs the water drainage hole at the rear/bottom of the freezer compartment.
    Sounds like the defrost water drain may be plugged. You can read about what may need to be done to correct such a condition on several different makes and designs of refrigerators at the following link:

    LINK > My fridge is leaking water, what might the problem be?

    JMO

    Dan O.
    www.Appliance411.com
    The Appliance Information Site
    =D~~~~~~

  4. #4
    Join Date
    Oct 2006
    Location
    Fairfax, VA
    Posts
    3

    Default Kirkland Signature (COSTCO Company) Whirlpool refrigerator

    I have the same problem with this unit.
    It is frost on the cooling coil from the top all the way down into the refrigerator compartment....
    Is there no defrost cycle here ? I have set the thermostat midway on the cold/coldest scale.
    This unit is in the company breakroom. Large cooling demand area.
    I have ordered the repair book...........

  5. #5
    Join Date
    Oct 2006
    Location
    Fairfax, VA
    Posts
    3

    Default

    Quote Originally Posted by jeff1
    Hi,

    **Ice builds up at the bottom of the freezer and clogs the water drainage hole at the rear/bottom of the freezer compartment.**

    Ice like an ice cube or frost like snow?

    If clear ice, the defrost drain system is likely clogged/restricted and the defrost water is not running away. The drain system would need to be cleaned/flushed out.

    **Kirkland Signature (COSTCO Company) Whirlpool refrigerator**

    Model#? These are just names.

    jeff.
    I have the same problem with this unit.
    It is frost on the cooling coil from the top all the way down into the refrigerator compartment....
    Is there no defrost cycle here ? I have set the thermostat midway on the cold/coldest scale.
    This unit is in the company breakroom. Large cooling demand area.
    I have ordered the repair book...........

Similar Threads

  1. Bad smell from Whirlpool Conquest Refrigerator
    By Rosemary in forum Whirlpool/Roper/Estate
    Replies: 2
    Last Post: September 23rd, 2010, 10:38 PM
  2. Whirlpool - ice on food in refrigerator
    By DaveS in forum Whirlpool/Roper/Estate
    Replies: 3
    Last Post: July 25th, 2006, 02:08 PM
  3. Loud vibrating noise Kirkland Signature Whirlpool Refrigerator
    By tiggerlmk in forum Whirlpool/Roper/Estate
    Replies: 3
    Last Post: January 24th, 2006, 04:41 PM
  4. Whirlpool Refrigerator Doesn't Cool
    By cksvih01 in forum Whirlpool/Roper/Estate
    Replies: 1
    Last Post: July 19th, 2005, 03:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog