Results 1 to 3 of 3

Thread: Frost on auger motor and frozen solenoid - GE Profile Arctica

  1. #1
    Join Date
    Sep 2009
    Location
    Madison
    Posts
    12

    Default Frost on auger motor and frozen solenoid - GE Profile Arctica

    Model Number: PSS25MGMACC
    Brand: GE
    Age: More than 10 years

    I noticed when I pushed the cube buttom, I'd only get crushed ice. After pulling the auger motor housing out, I noticed ice / frost on the motor and the solenoid was frozen. I let it defrost, dried it all off and reinstalled. This worked for a few weeks, but the ice / frost is back. I'm wondering if my ice maker might be leaking or if there is supposed to be a defrost heater around the area of the auger housing. There is some ice on top of the housing as well as inside on the bottom.

    I really appreciate any suggestions.

    Thanks,

    Jim

  2. #2
    Join Date
    Oct 2004
    Location
    Ontario, Canada
    Posts
    13,168

    Default

    Hi,

    ?Maybe?...

    TIP: A common trouble maker of late has been the dispenser motor freezing up and sticking and not turning to dispense the ice cubes. GE has come out with a couple of boot kits to help prevent the dispenser motors from getting frozen up.
    Electronic GE SxS boot #WR02x11295

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

  3. #3
    Join Date
    Sep 2009
    Location
    Madison
    Posts
    12

    Default

    Thanks for the tip. I'll check it out. I suspect my ice maker motor is working ok since I am getting plenty of ice. I put a paper towel between the ice maker and the auger motor housing to see if I am getting any water collecting. I'll let you know what I find on both.

    Jim

Similar Threads

  1. [FIXED] GE Arctica Freezer Not Frozen
    By bruin22anton in forum GE/Hotpoint
    Replies: 11
    Last Post: March 3rd, 2011, 06:03 PM
  2. [FIXED] Auger motor issue; motor not getting power
    By 75ohm in forum Sears Kenmore
    Replies: 11
    Last Post: December 30th, 2010, 10:06 PM
  3. Replies: 14
    Last Post: August 22nd, 2010, 12:57 PM
  4. GE Arctica - Water/Ice Dispenser frozen
    By karen Kearney in forum GE/Hotpoint
    Replies: 1
    Last Post: October 1st, 2006, 10:51 AM
  5. Replies: 1
    Last Post: March 6th, 2006, 03:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog