Social Buttons
Results 1 to 6 of 6

Thread: GE Profile Gas Range Probe Sensor Problem

  1. #1
    Join Date
    Oct 2012
    Location
    United States
    Posts
    3

    Default GE Profile Gas Range Probe Sensor Problem

    Model Number: PGB916SEMSS
    Brand: GE
    Age: 1-5 years

    Greetings,

    For quite some time now whenever I preheat the oven the probe sensor beeps for several minutes and then quits. I don't believe I have ever actually used the probe. Otherwise the unit works just fine. Obviously I can live with this new feature but suspect that someday the issue(s) will get worse. Suggestions?
    Last edited by Jake; October 30th, 2012 at 11:03 AM. Reason: Corrected model number

  2. #2
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,876

    Default

    Hi,

    We need the full model number. Your missing some digits in it.

    Click here: Appliance Parts at RepairClinic. 125 Brands. 365 Day Returns.

    Then you will see a link that says: Help me find my model number.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  3. #3
    Join Date
    Oct 2012
    Location
    United States
    Posts
    3

    Default

    Quote Originally Posted by Jake View Post
    Hi,

    We need the full model number. Your missing some digits in it.

    Click here: Appliance Parts at RepairClinic. 125 Brands. 365 Day Returns.

    Then you will see a link that says: Help me find my model number.

    Jake
    My bad. I didn't proof my entry very well. I have the original receipt. Model # PGB916SEMSS.

    Now trying to figure out how to edit original post.

  4. #4
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,876

    Default

    Thanks,

    So are you talking about the meat probe? Cant you just remove the probe from the oven?

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  5. #5
    Join Date
    Oct 2012
    Location
    United States
    Posts
    3

    Default

    Quote Originally Posted by Jake View Post
    Thanks,

    So are you talking about the meat probe? Cant you just remove the probe from the oven?

    Jake
    Yes, the meat probe. It is not installed. Never has been. Still in the drawer next to the stove where I put it in 2009 when I bought this stove.

    The problem is the probe sensor display on the stove console blinks and beeps for no apparent reason for several minutes while the oven is preheating. Sorry if I was ambiguous.

    My guess is this blinking/beeping event is what is suppose to happen when you are using the probe and the sensor reaches the desired temp, i.e., time to take the roast out of the oven. Seems odd since I have never programmed the stove to use the sensor. Maybe I should try it and see what happens. Perhaps a pot of water in the oven w/ the sensor probe immersed would be an interesting experiment.

    Some months ago I tried resetting the stove electronics by turning the circuit off for a few minutes. That had no affect.

    I'll try my new experiment this evening.

  6. #6
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    69,876

    Default

    Oh ok, got it.

    Yes I'm not sure why its beeping then, I haven't run into that issue before.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

Similar Threads

  1. Suberba Meat Probe Problem
    By bbranan in forum KitchenAid
    Replies: 4
    Last Post: December 9th, 2011, 04:37 PM
  2. KitchenAid Superba keypad + probe problem
    By porkchop1113 in forum KitchenAid
    Replies: 1
    Last Post: June 15th, 2010, 11:47 PM
  3. Meat Probe Indicator problem
    By BrianD in forum KitchenAid
    Replies: 0
    Last Post: November 7th, 2007, 03:29 PM
  4. Jenn Air Range- Probe Pad Error
    By cookswithgas in forum Maytag/Magic Chef/Admiral/Jenn-Air
    Replies: 3
    Last Post: September 6th, 2007, 09:44 AM
  5. GE Profile DPSB620 gas dryer sensor cycle problem
    By Catamount in forum GE/Hotpoint
    Replies: 1
    Last Post: June 6th, 2006, 10:49 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog