Results 1 to 8 of 8

Thread: Built in KitchenAid Oven/Microwave (KEMC378KBL0) stopped working

  1. #1
    Join Date
    May 2013
    Location
    California
    Posts
    4

    Default Built in KitchenAid Oven/Microwave (KEMC378KBL0) stopped working

    Model Number: KEMC378KBL0
    Brand: KitchenAid
    Age: More than 10 years

    My 11 year old KitchenAid oven/microwave suddenly stopped working. The display is completely dead. The only thing that works is the light in the microwave. The big fuse on top is fine.
    Any thoughts?

    Thanks very much!

  2. #2
    Join Date
    Jul 2006
    Location
    Murray, Utah, United States
    Posts
    18,149

    Default

    Hi Bret, OK, the first thing to check is the control transformer. The control transformer supplies the low voltage for the display and electronic control board. Check for 120 VAC between the wires on the primary side of the transformer, black wire and white wire.
    Click image for larger version. 

Name:	KEMC387 01.jpeg 
Views:	79 
Size:	105.2 KB 
ID:	10632Click image for larger version. 

Name:	KEMC387 02.jpeg 
Views:	83 
Size:	61.5 KB 
ID:	10633
    OWNER RICK'S APPLIANCE REPAIR
    APPLIANCE TECHNICIAN FOR 29 YEARS
    REFRIGERATION SPECIALIST
    ONLINE SERV TECH: ApplianceBlog.com
    CERTIFIED TYPE 1; TYPE 2.....REFRIGERATION SERVICE E.S.

  3. #3
    Join Date
    May 2013
    Location
    California
    Posts
    4

    Default

    I will try it out tonight. Thanks

  4. #4
    Join Date
    Jul 2006
    Location
    Murray, Utah, United States
    Posts
    18,149

    Default

    OK, sounds good. Keep us posted.
    OWNER RICK'S APPLIANCE REPAIR
    APPLIANCE TECHNICIAN FOR 29 YEARS
    REFRIGERATION SPECIALIST
    ONLINE SERV TECH: ApplianceBlog.com
    CERTIFIED TYPE 1; TYPE 2.....REFRIGERATION SERVICE E.S.

  5. #5
    Join Date
    May 2013
    Location
    California
    Posts
    4

    Default

    I checked it and it has power. What can I check next?

  6. #6
    Join Date
    Jul 2006
    Location
    Murray, Utah, United States
    Posts
    18,149

    Default

    Bret, check the three secondaries for the correct voltage. The voltages are listed in the diagram. If the voltage is correct, the EOC is faulty:
    Control Board 8302985 Order now for same day shipping. 365 day return policy. RepairClinic.com
    Click image for larger version. 

Name:	Control-Board-8302985--00661529.jpg 
Views:	38 
Size:	63.7 KB 
ID:	10656
    OWNER RICK'S APPLIANCE REPAIR
    APPLIANCE TECHNICIAN FOR 29 YEARS
    REFRIGERATION SPECIALIST
    ONLINE SERV TECH: ApplianceBlog.com
    CERTIFIED TYPE 1; TYPE 2.....REFRIGERATION SERVICE E.S.

  7. #7
    Join Date
    May 2013
    Location
    California
    Posts
    4

    Default

    Thanks Rick

  8. #8
    Join Date
    Jul 2006
    Location
    Murray, Utah, United States
    Posts
    18,149

    Default

    Anytime my friend!
    OWNER RICK'S APPLIANCE REPAIR
    APPLIANCE TECHNICIAN FOR 29 YEARS
    REFRIGERATION SPECIALIST
    ONLINE SERV TECH: ApplianceBlog.com
    CERTIFIED TYPE 1; TYPE 2.....REFRIGERATION SERVICE E.S.

Similar Threads

  1. Replies: 1
    Last Post: February 2nd, 2013, 10:47 PM
  2. Ge Monogram built in Microwave/convection oven
    By smachleal in forum GE/Hotpoint
    Replies: 3
    Last Post: October 10th, 2012, 06:02 AM
  3. Replies: 2
    Last Post: August 15th, 2012, 08:51 AM
  4. Replies: 0
    Last Post: January 29th, 2012, 10:07 AM
  5. Kitchenaid Superba gas oven stopped working
    By PeaJay in forum KitchenAid
    Replies: 11
    Last Post: November 21st, 2011, 11:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog