Results 1 to 5 of 5

Thread: Kenmore 580 spitting ice - help!

  1. #1
    Join Date
    Jun 2006
    Location
    Seattle
    Posts
    2

    Default Kenmore 580 spitting ice - help!

    I have a Kenmore 580 air conditioner that seems to freeze up a little or something as it spits out little ice chips and make clanking sounds after running for about 20 mins. When I let the fan run for awhile it seems to melt whatever froze up and the noise and ice chips stop. When I turn the A/C mode back on; however, the ice and noise start again. Any suggestions, cures, etc. out there? Thanks.

  2. #2
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    68,285

    Default

    Check your filter in front, make sure its clean.

    Leave the fan on continuously while the compressor cycles on & off.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  3. #3
    Join Date
    Oct 2004
    Location
    Ontario, Canada
    Posts
    13,177

    Default

    Hi,

    An air conditioner that constantly ices up will need to be repaired. It can be due to a lack of refrigerant, bad fan motor, or inefficient compressor. Or it may simply need to be dismantled and professionally cleaned. This involves the use of equipment and tools only your service company will have.

    Machine works properly during day, but ices up at night?
    Probably because outside temperature falling below 60 degrees Fahrenheit during night. This allows the air conditioner to produce frost on the inside coil. This problem usually occurs in the fall when days are warm, but the nights start to get cold.
    If icing occurs when temperature is above 60 degrees Fahrenheit then the air conditioner will need servicing.

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

  4. #4
    Join Date
    Jun 2006
    Location
    Seattle
    Posts
    2

    Default

    Checked the filter and cleaned it - didn't make a difference. The ice "chipping" occurs during the day - don't need the A/C at night here. I let the fan run and after awhile (30-45 minutes), the ice and noise stops. I'm not sure if it melts or what. The thing is practically new (bought last year and only used a few times) so I'm not sure what's wrong with it.

  5. #5
    Join Date
    Oct 2004
    Location
    Ontario, Canada
    Posts
    13,177

    Default

    The thing is practically new (bought last year and only used a few times)
    Still under warranty?
    If yes, call and have it checked out.

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

Similar Threads

  1. FIXED: Kenmore Coldspot Ice Maker Stopped Working
    By Izumino in forum Sears Kenmore
    Replies: 13
    Last Post: June 27th, 2014, 10:55 AM
  2. Sears Kenmore Ice Maker Overflowing
    By ArtTruex in forum Sears Kenmore
    Replies: 1
    Last Post: June 3rd, 2007, 11:16 PM
  3. Kenmore Elite Not Making Ice
    By jbp71 in forum Sears Kenmore
    Replies: 5
    Last Post: April 18th, 2007, 10:43 AM
  4. Kenmore elite not dispensing ice
    By dkap in forum Sears Kenmore
    Replies: 1
    Last Post: April 13th, 2007, 09:44 PM
  5. Kenmore Elite Ice Spills in Bottom Freezer
    By chemjaneer in forum Sears Kenmore
    Replies: 6
    Last Post: March 8th, 2007, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog