Results 1 to 9 of 9

Thread: GE Monogram

  1. #1
    Join Date
    Aug 2006
    Location
    Michigan
    Posts
    3

    Default GE Monogram

    We have a GE Monogram s/s and the fan motor in the freezer keeps icing up and then will not run. What would be causing this?

  2. #2
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    67,097

    Default

    Hi,

    Whats the model#?

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  3. #3
    Join Date
    Aug 2006
    Location
    Michigan
    Posts
    3

    Default

    I do not know what the model # is, I cannot find it on the frig anywhere and cannot find the manual either.

  4. #4
    Join Date
    Aug 2006
    Location
    Michigan
    Posts
    3

    Talking

    This is a built in s/s with the condensor and fan on the top of the frig/freezer.

  5. #5
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    67,097

    Default

    Oh, so its a built-in model?

    Sorry, I don't have any repair experience on built-ins.

    Hopefully another tech. or member can help you out.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  6. #6
    Join Date
    Sep 2006
    Location
    Minneapolis, MN
    Posts
    4

    Default water from condenser on top

    sou nds like you have the same problem I have

    I have a ZISB42DYb s/s builtin monogram

    The ice comes from the top condesnor and drains into the freser, sometimes covering up the moters - it seems the drian gets cloged or does not work well

    I can not see how the drain tube goes from the bottom of the condeser unit to the bottom of th evaprator unit

    I suspect the bottom header is not keeping the watter flowing in the correct direction, to the rt to the evaporator

  7. #7
    Join Date
    Aug 2007
    Location
    Los Angeles
    Posts
    3

    Default

    I see this post is very old. Have you solved the problem and what was it that was done? I am starting to work on Mono's and am trying to collect whatever feedback I can get...

  8. #8
    Join Date
    Aug 2007
    Location
    NY
    Posts
    9

    Default

    Quote Originally Posted by reeferman View Post
    I see this post is very old. Have you solved the problem and what was it that was done? I am starting to work on Mono's and am trying to collect whatever feedback I can get...
    Most of the time, the problem in this thread is caused by a clogged condensate tube. It could also be caused by a failed condensate pan heater, condensation build up on the evap compartment ceiling etc... The fix is a GE icing kit part# WR49X10021. It is a difficult job. Unless you have done many of these, I suggest you pass on this job and refer the customer to GE factory service.

  9. #9
    Join Date
    Jan 2007
    Location
    San Diego CA
    Posts
    131

    Default

    VERY common problem on GE built ins, model # ZISB or ZISW

    Poor insulation of the upper evaporator box.

    Ive seen some with a heater installed but it didnt do a very good job.
    Econo Appliance Service - San Diego appliance repair experts!

Similar Threads

  1. GE Monogram Fails to Cool
    By pbear in forum GE/Hotpoint
    Replies: 2
    Last Post: August 2nd, 2007, 06:13 PM
  2. GE Monogram no ice/low freezer cool
    By wbuster1 in forum GE/Hotpoint
    Replies: 1
    Last Post: March 29th, 2007, 08:29 PM
  3. Monogram Ventilation Hood ZV950SD
    By ng622 in forum Ranges/Ovens
    Replies: 1
    Last Post: December 5th, 2006, 11:23 AM
  4. GE Monogram drain plug issue
    By conviso in forum GE/Hotpoint
    Replies: 4
    Last Post: September 17th, 2006, 12:08 AM
  5. GE Monogram Water Reservoir Freezing
    By jldaddy in forum GE/Hotpoint
    Replies: 3
    Last Post: August 19th, 2006, 10:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog