Results 1 to 2 of 2

Thread: Kenmore electric range -oven problem

  1. #1
    Join Date
    Feb 2007

    Default Kenmore electric range -oven problem

    Mod# C970-657093 Kenmore electric range.

    The oven does not heat up.
    The glass cooktop works fine, and no error codes are displayed, but none of the elements in the oven work, no matter what the temperature setting. The convection fan works.


  2. #2
    Join Date
    Aug 2004
    McMullen Valley, Arizona


    Do a forum search here for this issue and you should find lots of posts about what to look for.

    Here is a good help link for your range too:

    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

Similar Threads

  1. Kenmore model 790.96612401 oven door problem
    By hammesd in forum Sears Kenmore
    Replies: 18
    Last Post: November 11th, 2015, 09:31 AM
  2. Frigidaire Range - Ongoing problems with EOC (electric Oven Contoller)
    By filterthespam in forum Frigidaire/Tappan/Electrolux
    Replies: 1
    Last Post: February 23rd, 2007, 02:32 AM
  3. Kenmore Model No. 665.9200 electric range
    By opusfly69 in forum Sears Kenmore
    Replies: 3
    Last Post: March 8th, 2006, 02:23 AM
  4. Kenmore Select Clean Range Oven Problem
    By jsebski in forum Sears Kenmore
    Replies: 5
    Last Post: February 6th, 2006, 10:14 PM
  5. Slow Preheat with Kenmore Electric Range
    By bigredrocket in forum Sears Kenmore
    Replies: 1
    Last Post: January 22nd, 2006, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!
Facebook Page: ApplianceBlog Twitter: ApplianceBlog Google+ YouTube: ApplianceBlog