10 year old Whirlpool dishwasher has never worked

Dana P.

Premium Member
Joined
Mar 16, 2016
Messages
3
Location
Bethesda,Ohio
Model
GU2500XTPQ7
Brand
Whirlpool
Age
6-10 years
When I built this house I put all Whirlpool appliances in, that was in 2006. We didn't use the dishwasher but I did accidentally hit the start button once and it started. About 3 or 4 years ago it had some lights start blinking. It would not start. The normal cycle light has been blinking about 3 times a second for at least 2 years. I don't think I ever did have the water turned on to it. Do any of you have any idea what would be wrong with it?
Thanks, Dana
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,317
Location
McMullen Valley, Arizona
Do all the buttons respond when pressed? All you get is flashing lights on normal and start buttons?

If so that's usually a sign the control panel has a shorted key in it.

Here's the control panel assembly for your model:
Whirlpool 3385745 Panel-Cntl


Jake
 

Dana P.

Premium Member
Joined
Mar 16, 2016
Messages
3
Location
Bethesda,Ohio
Thanks for the reply Jake. None of the buttons respond when pushed. The only thing it does is the normal button blinks 3 times a second and has been doing so for about 3 years. Is what I described here an indication of a shorted out button? Will the buttons short out from lack of use? This thing has never had a drop of water in it.
Dana
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,317
Location
McMullen Valley, Arizona
Yes Dana, That's what's odd is its never been in use, you may want to at least open the control panel and take a look to see if the control panel ribbon cable may just be loose where it connects to the control board.

Watch this video to access it:

Now some models don't have that black cover you see in the video, just ignore that step if yours doesn't.

<IFRAME title="YouTube video player" height=390 src="https://www.youtube.com/embed/FhsuRn6ysbc?rel=0" frameBorder=0 width=640 allowfullscreen></IFRAME>

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,317
Location
McMullen Valley, Arizona
Glad to help Dana!

Jake
 
Top