FIXED 106.56233400 Fridge water dispenser periodically starts flowing water on its own.

CHolt

Premium Member
Joined
Oct 18, 2014
Messages
11
Location
Ontario
Model Number
106.56233400
Brand
Sears Kenmore
Age
6-10 years
My Kenmore fridge has started to periodically begin dispensing a full flow of water from the water dispenser completely on its own. We were lucky to be home at the time and were able to get the water valve shut before having a flood. The solenoid valve seems to periodically get an electrical current to open and stay on. I have tried shutting the fridge off, both at the control panel and unplugging it, and then restarting it. It could go for a few hours to a few days before it does this again. Between those times it would manually dispense fine. Aside from this the rest of the fridge appears to be working fine. The dispenser couldn't be trusted so I currently have the electrical connector disconnected to the dispenser side of the valve. This way it has continued to make ice OK. I am not an appliance repairman but I am currently thinking it may be the main control board for the fridge. I am seeking additional opinions before I spend the money on a new circuit board.

Note:
I already changed the water valve only 6-8 months prior to this when I noticed the ice dispenser was continuing to drip water into the fill cup inside the freezer after the water should have shut off. This was causing the fill cup and fill hose to freeze up and stop making ice. Changing the valve had corrected this issue.

Your opinions would be appreciated. Thanks.
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,708
Location
Ontario, Canada
Hi,

Just a guess, maybe the micrswitch in the dispensor is sticking on keep it energized?

Micro-Switch-2162361-00564282.jpg LINK> Micro switch

[video=youtube;BlAcB5rJugI]https://www.youtube.com/watch?v=BlAcB5rJugI&feature=player_embedded[/video]

jeff.
 

CHolt

Premium Member
Joined
Oct 18, 2014
Messages
11
Location
Ontario
Thanks. When I have a chance I will see what is involved in gaining access to the switch and test it. The main reason I didn't think it was the switch sticking is that it had started flowing on a few occasions when no one was even in the kitchen or activating it. Once it did start flowing though, there were times even after the water was shutoff that I would still hear humming from the valve and I would have to either unplug the connector at the valve or do a reset to the fridge to get it to stop.
 

CHolt

Premium Member
Joined
Oct 18, 2014
Messages
11
Location
Ontario
Update. This was the initial issue that was discovered with this unit but then the fridge compressor also quit working. This was discussed in a separate post. In the end it was found that there was a burnt wire in the main wire harness connector at the bottom rear of the fridge. That wire was reconnected and I also plugged the connector back in at the water valve. It has now worked for a couple of weeks with no unexpected water dispensing issues during this time. I am assuming that the two issues were related. Possibly the wire that was burnt was causing a short to the feed for the water valve. Not sure.
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,708
Location
Ontario, Canada
Weird issue....thankx for the update :)

jeff.
 
Top