Results 1 to 4 of 4

Thread: LG Range Not Working - LDE4415ST

  1. #1
    Join Date
    Apr 2018
    Location
    MN
    Posts
    2

    Default LG Range Not Working - LDE4415ST

    Model Number: LDE4415ST
    Brand: LG
    Age: 1-5 years

    Hello,
    I have an LG Double oven (LDE4415ST) that recently became 100% unresponsive during a cooking cycle. The display wouldn't turn on, not would the burners on the cooktop. The 'burner on" indicator light did work. After some research and testing I replaced a failed thermostat for the bottom oven, which fixed the issue temporarily. Unfortunately, upon first use of the bottom oven the issue occurred again. I replaced the thermostat again and the unit has continued to work as long as the bottom oven is not used.

    I'm looking for any wisdom from those much more knowledgable than I am in this area as I try to figure out what to try next. Should I pay the expense for a new main board and swap that out? Is there someone else local to the bottom oven that I should try instead?

    Thanks,
    J

  2. #2
    Join Date
    Jul 2006
    Location
    Murray, Utah 84107, United States
    Posts
    29,446

    Default

    What's the part number of the thermostat you just replaced and where's it located on your range? It sounds like one of the bottom elements may have shorted. Use a meter and check them for continuity.
    OWNER RICK'S APPLIANCE REPAIR
    APPLIANCE TECHNICIAN FOR 31 YEARS
    REFRIGERATION SPECIALIST
    ONLINE SERV TECH: ApplianceBlog.com
    CERTIFIED TYPE 1; TYPE 2.....REFRIGERATION SERVICE E.S.

  3. #3
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    91,184

    Default

    Also, we noticed you may have inverted the 4 and the 5 in your model number, can you please check your model number again?

    LDE4515ST<---Does not pull up as good
    LDE5415ST<---Good model number

    Here's the parts diagram for LDE5415ST: LG Range LDE5415ST / Repair Parts

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  4. #4
    Join Date
    Apr 2018
    Location
    MN
    Posts
    2

    Default

    Thank you both for your responses! I did indeed make an error in the model number. The correct model is LDE4415ST. The thermostat part # is 6930W1A003X. Depending on where I see the part listed it shows up as either a thermal fuse or thermostat. It is screwed to the back panel directly behind the lower oven. It was bad, and upon replacing it the Range worked as expected until the lower oven was used again. My wife turned on self-cleaning mode and that caused the entire range to go dead again. Swapped in another new thermostat and the range has worked as expected as long as we don't use the bottom oven.

    I haven't yet had a chance to tear it apart gain to test the element for continuity. Will report back once I have results of that test.

    Thanks again,
    Jesse

Similar Threads

  1. Replies: 3
    Last Post: October 7th, 2017, 07:03 PM
  2. GE range Controller not working right?
    By sparkync in forum GE/Hotpoint
    Replies: 1
    Last Post: January 31st, 2015, 10:04 PM
  3. Range not working
    By unameit in forum Maytag/Magic Chef/Admiral/Jenn-Air
    Replies: 3
    Last Post: August 28th, 2013, 11:21 PM
  4. radiant range not working
    By shogan in forum Sears Kenmore
    Replies: 7
    Last Post: January 7th, 2007, 04:35 PM
  5. Range not working
    By Jerry Barnes in forum Whirlpool/Roper/Estate
    Replies: 3
    Last Post: May 5th, 2005, 08:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!