Results 1 to 1 of 1

Thread: Rinse, Drying, End lights flashing on Miele G2140

  1. #1
    Join Date
    Jun 2018
    Location
    Toronto
    Posts
    1

    Default Rinse, Drying, End lights flashing on Miele G2140

    Model Number: Miele G2140
    Brand: other
    Age: More than 10 years

    Miele G2140

    This problem started a couple of weeks ago on my 11 year old Miele (Inspira G2140) dishwasher. I put in the dishes in and loaded the powder detergent, and (as always) ran the Normal Cycle, and went to bed. Upon rising the dishes were wet, there was no water in the unit other than the small amount that is left by the drainage pump. And all 3 lights - rinse, drying and end - were flashing together. I went on line and read a posting on your site that sounded familiar. With the information I read on-line, performed the following checks:

    1) I reset the unit and ran the normal cycle again. In this case no water entered the Unit, so I checked the line in (no buildup that would cause a blockage).

    2) Took out the filter basket on the bottom of the unit and as best I could used my "two pronged fork" to see if the circulation pump impeller was stuck. On this model it's hard to tell if it was, but I wiggled it around. Again, when I ran it, no water came in. I ran a few more resets and memory clears, but with no luck.

    3) Called Miele's help number and talked to a service person who said it was the electronic heater element switch... Hummm...that didn't sound right, but maybe they're right.

    4) At this point I about to call a Miele repair guy who will probably tell me I need a new circulation pump to the tune of 750+ bucks.

    5) BUT then, a miracle happens a few days later, it just starts working. Perfectly. Like there was never anything wrong with it.

    6)Until, today, a week later the same problem starts again. Only, this time I'm a little more educated about it, so having discovered the dishes inside the machine had gone through the rinse cycle, (they were still a bit wet) but not the wash cycle and see that the rinse water had been been removed by the drainage pump, I tried a little test.

    7) After doing a number of 'resets' I ran the 'rinse and hold' cycle and lo and behold the water entered the machine, and it went through a complete rinse cycle, including draining the water from the machine. (So the circulation - and drainage - pumps seem to work...)

    8) But when I then tried the Normal cycle it went back to not letting ANY water into the machine.

    9) And when I tried, again as a test, to run just the 'rinse and hold' cycle, this time no water entered.

    10) So the problem is intermittent - which suggests some kind of electrical issue - but of course I'm only guessing.

    Can anyone help me here? It's infuriating to think that a repair person will show up and give me a new pump when this one seems to be capable of working - albeit intermittently. Any thoughts?
    Last edited by Rosco; June 3rd, 2018 at 10:11 AM.

Similar Threads

  1. Replies: 6
    Last Post: December 29th, 2017, 10:08 AM
  2. Replies: 1
    Last Post: December 9th, 2015, 02:01 AM
  3. Replies: 3
    Last Post: June 7th, 2015, 10:16 AM
  4. Washing, Drying and Clean Lights Flashing
    By curtisdsc in forum Sears Kenmore
    Replies: 3
    Last Post: September 30th, 2013, 08:56 PM
  5. Electrolux EIDW6105 Lights Flashing and Drying Damper Error Light Lit
    By starzbullies in forum Frigidaire/Electrolux Reviews
    Replies: 8
    Last Post: October 24th, 2012, 09:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!