• Please note, some of the links on our site are affiliate links (Learn More)

FIXED 665.13219K901 Kenmore Dishwasher strange behaviour

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
Model Number
665.13219K901
Brand
Sears Kenmore
Age
6-10 years
Good evening everyone,

I am having some issues with my Kenmore 665.13219K901 dishwasher. A few days ago I noticed that after the dishwasher finished washing, there was water remaining in the bottom of the tub. I was able to drain it using the cancel/drain button The next day when I tried to run a cycle the "normal wash" light would flash continuously and the only other button that worked was the "cancel/drain" which would also flash. I tried turning off the breaker for a time which didn't seem to help.

I read up on several forums and opened up the dishwasher to see if I disconnected the control board from the control panel whether the dishwasher drain would work.....which it did. I managed to get the dishwasher into diagnostic mode twice and both times it stopped after around 10 minutes. I read somewhere online that the issue could be a stuck key on the keypad some I wiped it down with a damp towel and then wiped it with a clean towel. That seemed to get rid of the issues of the light flashing.

When I run a "normal wash" cycle now, the machine stays in "cleaning" for quite some time and the machine turns off and on by itself numerous times. Would anyone know of what the issue would be? I first thought it was the control panel because of the flashing lights and the fact that the drain would work when the control board was disconnected but now I'm not so sure.
Thanks in advance!
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
39,659
Location
Murray, Utah 84107, United States
Run the service diagnostic cycle and check for error codes.

Invoking Service Diagnostics clears all status and last ran information from memory and restores defaults; it also forces the next cycle to be a sensor calibration cycle.

Calibration cycle forces two rinses to occur prior to Final Rinse (to assure clear water), then calibrates the OWI during the final rinse.

The Service Diagnostic Cycle has 27 intervals and will take about 25 minutes.

The Service Diagnostic Cycle starts with interval 27 and ends on interval 1. NOTE: Some models have replaced the “Clean” LED with “Completed.”

Press; HEATED DRY > NORMAL > HEATED DRY > NORMAL > HEATED DRY > NORMAL

Interval 27 turns on all the LEDs as a display test even if the door is open

Intervals 26-25-24-23 are for Error codes, newest to oldest.

Interval 22 to Interval 3 is the diagnostic cycle.

Intervals 2 and 1 are for any error codes found during the diagnostic cycle.

The Clean (or Completed) LED will flash each error codes in 2 parts.

The Clean LED will flash the FUNCTION code, pause for 2 seconds, then flash the PROBLEM code, pause for 5 seconds then repeat 3 more times. Write down the error codes.

If there are no error codes the LED will stay solid for 5 seconds.
 

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
Thats one of the issues, I have tried to run it twice but like I said, both times after around 10 mins the machines stops and water is left in the bottom of the tub. I am able to drain it with the cancel/drain button
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
39,659
Location
Murray, Utah 84107, United States
like I said, both times after around 10 mins the machines stops
The error codes are displayed during the first couple minutes. Are you saying it will not enter service mode at all?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
39,659
Location
Murray, Utah 84107, United States
A blinking LED over one of the keys of the keypad (or sometimes a “dead” keypad/console) indicates one or more key switch lines are stuck or shorted on the control or the keypad. To determine if the control or keypad is faulty, do the following test:

Unplug dishwasher or disconnect power

Open the dishwasher door.

Open console and disconnect the keypad ribbon connection from the control (at P1).

Make sure all other connections are made. Put console back together.

Do not close the dishwasher door.

Plug in dishwasher or reconnect power.

Wait 5 seconds.

Close dishwasher door and monitor the control’s response.

➔If the control is OK (no longer sees shorts with the keypad unplugged), it will respond by turning on the drain motor for 2 minutes. Check and/or replace the keypad if the control responds OK.

➔If the control is not OK (still sees shorts with the keypad unplugged), then the drain motor will NOT respond. If drain motor does not start within 10 seconds, repeat or verify that all steps were followed, and then replace the control.

 

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
I can get it into service mode. I haven't noticed any of the lights flashing in the first few minutes though.

Yes, as I said in my original post I looked into the blinking light and the drain worked. Since then, I haven't had the issue again, the only issue I have now is that the dishwasher turns off and on once I try to complete a wash and doesn't advance to the end.

Actually, the only time I get the blinking lights is when the diagnostic mode ends early and I try to drain the water in the bottom of the tub....
 
Last edited:

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
39,659
Location
Murray, Utah 84107, United States
The link for the part you need is in my last post.
I can get it into service mode.
Interval 27 turns on all the LEDs as a display test even if the door is open
If the LEDs don't turn on you're not in service mode. If you can't get into service mode the problem is either the console or control. If you followed all the steps in post #5 exactly and the drain motor turned on, replace the console.
 

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
The link for the part you need is in my last post.


If the LEDs don't turn on you're not in service mode. If you can't get into service mode the problem is either the console or control. If you followed all the steps in post #5 exactly and the drain motor turned on, replace the console.

Thanks,

The lights do turn on in service mode but after 8mins or so all the lights go out.

I will double check the test in #5 tomorrow and report back
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,945
Location
McMullen Valley, Arizona

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
Just a quick update.

Ever since my last post I’ve been able to run a full cycle although the machine turns off and on several times by itself during the cycle. I haven’t had anymore blinking lights.
Do you still think the issue is the control panel?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,945
Location
McMullen Valley, Arizona
Yuppers, seems yours is intermittent. But as the old saying goes--->"If it does it once, it will do it again".:)

Jake
 

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
Would you recommend buying a “used” control panel? they seem to be a fraction of the price.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,945
Location
McMullen Valley, Arizona
Rick and I recommend NOT buying used parts.:)

Jake
 

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
Hi,

Sorry I haven’t responded for a while I had major heat pump issues.

I retested my machine and the drain motor comes on for 2 minutes so I’m assuming it’s my control panel that’s causing my issues. I took a look at my ribbon cable earlier (see attached picture). It looks like it’s corroded. I tried to clean it with a pencil eraser but that didn’t seem to work. Is it possible to only get a new ribbon connector instead of a complete new control panel?
 

Attachments

  • AA43BCC1-CE90-43F8-B3BB-57886EAAA9DC.jpeg
    AA43BCC1-CE90-43F8-B3BB-57886EAAA9DC.jpeg
    331.4 KB · Views: 34

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,945
Location
McMullen Valley, Arizona
Unfortunately the ribbon cable only comes with the control panel, and that's definety the problem.

Jake
 

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
Thanks,

Are there any videos to show how to change this control panel? I guess I need to remove the latch?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,945
Location
McMullen Valley, Arizona
Didn't you already remove the control panel? I see it in your photo already removed, just install the new control panel the opposite way you removed the old control panel.:)

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,945
Location
McMullen Valley, Arizona
I found this on Youtube, I believe its the same one yours is, all Kenmore 665 models are made by Whirlpool.


Jake
 

simonjsf

Premium Member
Joined
May 13, 2020
Messages
25
Location
Canada
Thank you very much. My part arrived today and the dishwasher is 10 mins through its first cycle and hasn’t had any glitches :)
 
Top