• Please note, some of the links on our site are affiliate links (Learn More)

665.14579N612 Kenmore dishwasher middle and upper spray arms are not spinning (but some water is coming out of them)

VanceDailey

Premium Member
Joined
Nov 22, 2022
Messages
2
Location
US
Model Number
665.14579N612
Brand
Sears Kenmore
Age
1-5 years
My Kenmore dishwasher Model 665.14579N612 has a problem with the upper spray arms not spinning but a weak stream of water can be seen coming out of the holes when I first open the door. The lower arm works fine when the diverter is controlling the lower arm and does not spin when the diverter is controlling the upper two arms.
I removed all debris from the upper arms. Water flows out of all the holes when I test the middle arm in the sink.
I removed the spray tower and ran water through it to confirm that it is not blocked.
I checked the flapper covering the unused hole where the middle rack slides into the spray tower. If there is a leak there it is minor.
I replaced the diverter motor when I originally thought the upper spray arms were not getting water.
I replaced the circulation pump with one I had on hand from my last Maytag dishwasher. The older Maytag pump motor is slightly larger but it fits perfectly. Both pumps seem to run fine (and the lower arm spins). I don't see any damage to the impellers.
I guess it's possible both pumps are bad but can a pump without damaged impeller blades work well enough to work the lower spray arm but not the upper arms?

The water level in the bottom of the dishwasher seems OK. The sump area is fully submerged and the rest of the bottom is covered by between 1" to 1/2" of water.
I am not aware of any filters to check other than the main removable food filter inside the dishwasher.

Note: I can't get into diagnostic mode. I have tried with the door open and the dishware in standby mode (no leds after unplugging and replugging) quickly hitting three buttons in the sequence 1,2,3,1,2,3,1,2,3 and closing the door but no joy. My model does not have a lot of buttons but I have tried different sets of three adjacent buttons in a left to right sequence.

I would appreciate any ideas as to what to check next. I am at a loss.
Thanks,
Vance
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top