Results 1 to 5 of 5

Thread: HIIP054C Bosch oven meat probe not recognized

  1. #1
    Join Date
    Sep 2016
    Location
    Canada
    Posts
    6

    Default HIIP054C Bosch oven meat probe not recognized

    Model Number: HIIP054C
    Brand: Bosch
    Age: 1-5 years

    The meat probe on my VERY expensive Bosch HIIP054C slide-in induction oven does not register when it's plugged in (usually...there's the odd time where it comes on after being plugged in and the oven has been cooking for a while).
    I gather I'll need to test the connectivity of the female socket in the oven, but wonder whether the probe might have gone bad. (I have never put it in the dishwasher or under water).
    Any advice on how to get started?
    Last edited by Entangler; October 11th, 2018 at 01:25 PM.

  2. #2
    Join Date
    Sep 2016
    Location
    Canada
    Posts
    6

    Default

    No advice since posting on the larger issue of how to get started, so would appreciate knowing: How do I check the removable meat probe to know if it's still good?

  3. #3
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    96,655

    Default

    Your thread has 236 views, seems no one has a Bosch Range that can tell you out of 236 people?

    I would be glad to help you if I knew, but unfortunately I don't. Now on a KitchenAid range I could tell you.

    I have not been able to locate the tech data sheet or service manual on this Bosch model.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  4. #4
    Join Date
    Sep 2016
    Location
    Canada
    Posts
    6

    Default

    Hi Jake
    Yes I was a bit surprised that no one has volunteered anything in the few months that this post has been up. I doublechecked the Model Number, and it's correct but the complete number is HIIP054C/01. I don't think the suffix should make any difference, but you'd know better than I would, for sure.
    It's a 30" slide-in induction range assembled in the US but I bought it in Canada.
    A bit of a frustration. If anyone happens to find the service instructions or at least the pages related to servicing the meat probe receptacle at the top left front of the oven, I'd be totally happy!

  5. #5
    Join Date
    Sep 2016
    Location
    Canada
    Posts
    6

    Default

    ….sorry....an induction stove and cooktop, not "range".
    In the meantime, I've tested the resistance change per temperature using a fluke meter and heated water. There's a nice curve response from 43 K-ohms at 84F to 4.3 K-ohms at 200F. So I'm guessing that the problem is in the stove, not the probe...so any advice on how to access the probe connector and wiring would be appreciated.

Similar Threads

  1. Meat probe needs calibrating
    By Drahuber in forum GE/Hotpoint
    Replies: 1
    Last Post: October 12th, 2015, 12:49 PM
  2. Kitchenaid meat probe
    By GMD in forum KitchenAid
    Replies: 3
    Last Post: December 21st, 2011, 12:58 AM
  3. FIXED: KEMS307GBL0 Kitchenaid Issues with Meat Probe
    By TheRASGuy in forum KitchenAid
    Replies: 9
    Last Post: March 21st, 2008, 01:48 PM
  4. Meat Probe Indicator problem
    By BrianD in forum KitchenAid
    Replies: 0
    Last Post: November 7th, 2007, 05:29 PM
  5. KA Micro/Oven Combo Meat Probe just comes on
    By BrianD in forum Whirlpool/KitchenAid Reviews
    Replies: 0
    Last Post: November 3rd, 2007, 06:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!