Results 1 to 1 of 1

Thread: HIIP054C Bosch oven meat probe not recognized

  1. #1
    Join Date
    Sep 2016
    Location
    Canada
    Posts
    3

    Default HIIP054C Bosch oven meat probe not recognized

    Model Number: HIIP054C
    Brand: Bosch
    Age: 1-5 years

    The meat probe on my VERY expensive Bosch HIIP054C slide-in induction oven does not register when it's plugged in (usually...there's the odd time where it comes on after being plugged in and the oven has been cooking for a while).
    I gather I'll need to test the connectivity of the female socket in the oven, but wonder whether the probe might have gone bad. (I have never put it in the dishwasher or under water).
    Any advice on how to get started?
    Last edited by Entangler; October 11th, 2018 at 01:25 PM.

Similar Threads

  1. Meat probe needs calibrating
    By Drahuber in forum GE/Hotpoint
    Replies: 1
    Last Post: October 12th, 2015, 12:49 PM
  2. FIXED: Kitchenaid Issues with Meat Probe
    By TheRASGuy in forum KitchenAid
    Replies: 12
    Last Post: July 15th, 2014, 06:11 AM
  3. Kitchenaid meat probe
    By GMD in forum KitchenAid
    Replies: 3
    Last Post: December 21st, 2011, 12:58 AM
  4. Meat Probe Indicator problem
    By BrianD in forum KitchenAid
    Replies: 0
    Last Post: November 7th, 2007, 05:29 PM
  5. KA Micro/Oven Combo Meat Probe just comes on
    By BrianD in forum Whirlpool/KitchenAid Reviews
    Replies: 0
    Last Post: November 3rd, 2007, 06:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!