Model Number: RTH2410
Brand: -major brand-
Age: 1-5 years


I think my Honeywell RTH2410 thermostat is having problems. When I run it in "Auto" mode it appears to start our furnace then about 5 mins then shuts it off. When I temporarily change temps the system doesn't kick in. I've attempted to reset it by taking the batteries out for a few minutes. When I reconnect it, I have to select "Set" and then "Run" for the system to engage. Then it runs for about 5 mins and shuts off. I have noticed it reading the temps in our house strangely too. It'll be 64 degrees then change to 69 then to 72 before eventually settling at 64. The other interesting part is, when the thermostat starts the furnace, I can hear the furnace kick on (flames blowing) for several seconds then turn off just before the blower fan starts. When I run in "fan only" mode, I hear the furnace start with the flames not stopping before the blower fan starts. I've had this thermostat for just over a year...are they prone to going back quickly?

Thanks for any advice.

Brian Willis