Results 1 to 4 of 4

Thread: Hoover dishwasher doesn't always work

  1. #1
    Join Date
    Nov 2018
    Location
    Madrid
    Posts
    2

    Default Hoover dishwasher doesn't always work

    Model Number: HEDS 100
    Brand: -major brand-
    Age: 1-5 years

    Hi,

    I've got a Hoover HEDS 100E/S which is a Candy13.1 type dishwasher.

    I've bought it around 2014. It's a white 45cm / 18" wide dishwasher with 3 buttons (delay start, program, start) a main switch and an display that shows the remaining time of the cycle. The dishwasher needs to be switched on by the main switch then all the lights on the dishwasher light up the only the display and program selector lights remain on. The desired program can be selected with the program button then by pressing the start a washing cycle starts. When a cycle is started the colon between the hour and minutes is flashing on the display. The dishwasher beeps while turned on and any of the buttons are pressed or the door is opened during a cycle.

    So the problem is that after a couple of months of usage the dishwasher beeped and stopped in the middle of the cycle then beeped and started again where it left. It didn't reset the program just stopped like when I open the door in the middle of the cycle then close it and it finishes from there. At first it didn't do it very often then it did it frequently. Often beeping minutes on end turning the cycle on and off but eventually went through the program and finished it.

    Around this time I had to move home and in the new house I had a dishwasher so I just put this hoover into the storage room and left there for 3 years until I moved home again.

    3 months ago I installed the dishwasher again in the new flat and to my surprise it started working flawlessly. No beeps, no broken cycles it did its job perfectly until about a month ago it started beeping in the middle of the cycle again and stopping. I've found out the if I keep the start button pressed (with a very unelegant toothpick) during the cycle then it isn't beeping nor stopping. It works as it should.

    This worked a couple of times but then it started to express its discontent with my novel solution and telling me something on its particular language that I don't get.

    When I switch it on with the main switch all the lights are flashing for a minute or so until the number 605 is displayed on its screen then starts to do some washing cycle unrelated to any washing program for a couple of minutes then stops displaying OA on the screen then it does nothing. Sometimes it displays a number 08 or 07 or 06 or 05 alternating with increasing number of minutes until it shows FO and stops.

    I figured if I disconnect the dishwasher from the main socket, sometimes it gets back to normal and I can quickly select the desired program then start it with a jammed start button. Unfortunately, this solution is starting to fail as not every time works when I need it.

    I guess the main PCB needs to be replaced but I wouldn't like to go through that pain if it isn't absolutely necessary.

    Does anyone have any idea what could be wrong and what exactly needs to be replaced or mended?

    Thanks!

  2. #2
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    95,178

    Default

    Hi,

    We don't have any tech information on European appliances here in the USA, sorry. You'll need to look for a European appliance repair forum in your area that can help you.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

  3. #3
    Join Date
    Nov 2018
    Location
    Madrid
    Posts
    2

    Default

    I understand that. I'll have a look around here too.
    However, if you had to guess what would you say about the possible problem?

  4. #4
    Join Date
    Aug 2004
    Location
    McMullen Valley, Arizona
    Posts
    95,178

    Default

    I guess the main PCB needs to be replaced
    I would agree.

    Jake
    Appliance Repair School 1987-1988
    Star Appliance Tech. 2 yrs. 1988-1990
    Wards Appliance Tech. 11 yrs. 1990-2001
    Sears Appliance Tech. 4 yrs. 2001-Oct. 2005
    Jake's Appliance Repair Nov. 2005-present

    Look-Up & Order Parts

Similar Threads

  1. Replies: 12
    Last Post: March 23rd, 2018, 12:16 AM
  2. Replies: 12
    Last Post: February 16th, 2018, 11:40 AM
  3. Replies: 5
    Last Post: June 1st, 2016, 12:45 PM
  4. Replies: 1
    Last Post: October 7th, 2012, 06:00 PM
  5. Replies: 7
    Last Post: July 24th, 2011, 02:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
If you feel that you have benefited from this site, and would like to show your appreciation, you can throw a buck or two in the Appliance Blog Tip Jar - Thank you!