790.41013800 "HE" indicators always on for two burners

DrAtomic

Premium Member
Joined
Jan 4, 2019
Messages
6
Location
the southeast
Model
790.41013
Brand
Sears Kenmore
Age
More than 10 years
Hi folks first time here. Guessing on age of range. I have researched what I can on the web and think it might be the burner control board, unless there are separate burner switches (?). If I'm correct, I can probably install a new control board if someone can help me with how to get to it..... thanks
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,318
Location
McMullen Valley, Arizona
Hi,

The HE (Hot Element) Indicator being ON all the time, even when its cooled indicates a problem in the burner sensor, not the control board.:)

Which two burners are doing this?

Jake
 

DrAtomic

Premium Member
Joined
Jan 4, 2019
Messages
6
Location
the southeast
I wondered about that, but couldn't find burner switches on the Sears website parts list. Any way it's the front two burners--the ones with the size selector option. Thanks
 

DrAtomic

Premium Member
Joined
Jan 4, 2019
Messages
6
Location
the southeast
From what I can tell, the switches are built in to the element units and aren't available separately. So replacing the burner units is the answer. Is this right?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,318
Location
McMullen Valley, Arizona
So replacing the burner units is the answer. Is this right?
You nailed it!

Here's the front burners for your model, they both are the exact same part number:
316282101 Element


Let us know how it goes.

Jake
 

DrAtomic

Premium Member
Joined
Jan 4, 2019
Messages
6
Location
the southeast
Great. I will order them. Never disassembled this type of unit. A quick look makes it seem like I start with the two screws on the front cowling below the control panel part of the top and that will reveal mounting screws for the top or some such thing. I'll search Youtube and see if I can find a video.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,318
Location
McMullen Valley, Arizona

DrAtomic

Premium Member
Joined
Jan 4, 2019
Messages
6
Location
the southeast
OK, little delay (life happens) but got around to doing this yesterday. Everything went well (both elements work correctly) until I discovered that after the repair, "F23" comes up when trying to use the any of the bake functions. Research indicates F23 is a comm error between control board and convection motor. When I attempt to use the broil function, the oven resets and the clock blinks like the power had been out. Circuit breaker at panel does not trip. Obviously I must have done something to the wiring I disconnected but I have checked it twice and it appears that I put everything back correctly and all of the connections are tight.

Am I going to have to make the call of shame and have a professional come in and fix my screwup?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,318
Location
McMullen Valley, Arizona

DrAtomic

Premium Member
Joined
Jan 4, 2019
Messages
6
Location
the southeast
yeah, I had found and printed that same diagram off before messaging you. Didn't help much, unfortunately. Can't see how I could have done it. All the connectors are different configurations and most are keyed. I would have had to try really hard to get something to fit where it doesn't belong. Checked it four times now and it all looks right. Guess it's time to suck it up and make the call. Thanks again for taking the time to try and help. Luckily I have a countertop unit I can use to make nachos--Go Pats!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,318
Location
McMullen Valley, Arizona
Ok,

It has to be a electrical connection that accidently came loose when you replaced those burners, because this F23 wasn't happening before you replaced the burners correct?

I would triple check all your electrical connections in the back of your range.

Luckily I have a countertop unit I can use to make nachos--Go Pats!
Pats won the superbowl.:)

I'm not a Rams fan even though I live closer to Los Angeles than New England.

Jake
 
Top