• Please note, some of the links on our site are affiliate links (Learn More)

FIXED 790.42003605 Kenmore Pro Electric Double Wall Oven - beeps constantly and digital gauges swing constantly +/-100 degrees, now top does not work.

Status
Not open for further replies.

RJF

Premium Member
Joined
Dec 5, 2020
Messages
4
Location
Arizona
Model Number
790.42003605
Brand
Sears Kenmore
Age
More than 10 years
My Kenmore Pro Electric Double Wall Oven was manufactured March 2010. Six months ago both ovens started to have digital temperature readout swings +/-100 degrees from their manual dialed set points while on Bake. We never tried any other mode. Example: As soon as the mode dial was turned to Bake (with its temperature dial set at 375 degrees) the digital temperature readout would immediately show 375 degrees, and then as it warmed up it would randomly show 475 degrees, then immediately show 300 degrees, then immediately show 410 degrees, then immediately show 225 degrees ... and so on, with constantly different numbers and beeping throughout the whole warm up and the entire Bake cycle. I tried turning power off at breaker then on...same problem.

Now when either the top or bottom ovens are FIRST set to Bake, Conv Bake, or Conv Roast it sounds like the ovens are coming on, but the top never gets very warm, in fact, the mechanical temperature needle does not get past the Warm & Hold lettering that is at about 7 o'clock on its dial. The bottom oven works, but still has the problem identified in the first paragraph, above.

Lastly, on either oven if you INITIALLY FIRST turn the mode dial to any other cook setting (except for Bake, Conv Bake or Conv Roast) ... like Broil, or Clean, or Warm & Hold, or Bread Proof, the ovens shut down with "err" showing. It clears the err message if you turn the mode dial to OFF. Also, if you have either oven INITIALLY set to Bake, Conv Bake, or Conv Roast, even for a minute, and then turn it to any other mode it will shut down with err showing. For instance, if you start in Conv Bake all is fine, but turn to Bake it generates an err message and shuts down.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
128,974
Location
Redmond, Oregon
Rick helped another member with this problem here:

It turned out to be this analog control board(your model uses this exact same analog control board):
Oven Control Board 316460201

It's in-stock here:

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
128,974
Location
Redmond, Oregon
Ok, sounds good.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
128,974
Location
Redmond, Oregon
Excellent RJF, glad to hear the new analog control board fixed it.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top