790.440481 Won't bake or broil

UkululeMark

Premium Member
Joined
Apr 24, 2019
Messages
3
Location
Quebec
Model
790.440481
Brand
Sears Kenmore
Age
More than 10 years
Hi,

My electric oven stopped working while baking. The clock and stove top burners still work. Neither the broiler or bake elements work now.

I tested the elements with a meter and they are fine.
The thermostat gives a resistance of 1100 ohms
There are 2 thermostats ontop of the oven. The front one shows continuity. The back one with part number 318003615 shows an open circuit. Is this good. Is it for the fan (that means it only completes the circuit when hot). Should I replace this thermostat or is the control board buggered.

Cheers Mark
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
33,117
Location
Murray, Utah 84107, United States
This is a Canadian model so I can't look up the wiring diagram. Measure the voltage across L1 and L2 on the electronic control. Should be 220 VAC. Then set to bake an measure the voltage across L1 and Bake or L2 OUT Should be 220 VAC.
 

UkululeMark

Premium Member
Joined
Apr 24, 2019
Messages
3
Location
Quebec
Hi Rick,

Thanks for replying. There is no L2. Just an L2_In and an L2_OUT

L1 to L2_IN is 1V
L1 to L2_OUT is 220

Turn on Bake

L1 to L2_IN is 0
L1 to L2_OUT is 220
L1 to Bake is 0V

The fan comes on for convection bake. I hear a buzzing from the relays. Does this mean the board is bad.

Cheers Mark
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
33,117
Location
Murray, Utah 84107, United States
That's exactly what it sounds like. Unfortunately I can't give you a part link.
 

UkululeMark

Premium Member
Joined
Apr 24, 2019
Messages
3
Location
Quebec
Hi Rick,

Thanks for your help. Part is 3162722208. This is discontinued and unavailable. Either I use a repair service which exist here in Quebec or I get myself a shiny new range.

Cheers Mark
 
Top