• Please note, some of the links on our site are affiliate links (Learn More)

790.75503202 Kenmore Oven won't heat up right

Dwhenry

Premium Member
Joined
Mar 11, 2020
Messages
8
Location
Karthaus Pa
Model Number
790.75503202
Brand
Sears Kenmore
Age
6-10 years
Suddenly oven won't heat up right. It takes forever to get to 160 and then stops. I googled oven won't heat up several times and found a video that was about the 5 most common causes and checked them out with my meter. The Bottom element continuity checks out, but it never turns red getting it to 160, temp probe tests fine, nothing wrong with outlet power. Small side oven was working then I took the temp probe out to test and put it back in. Now that oven isn't working either! Omg! Hoping someone can help! Had a delivery to an local appliance shop and explained my problem to the technician. He told me if I had 120v to the clock it was fine so I took it apart again and that tested fine.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,941
Location
Murray, Utah 84107, United States
The problem is most likely the ERC and unfortunately it's been discontinued and is no longer available. Access the ERC (clock). Select bake and start. Measure the voltage across E1 (L1) and E7 (BA). If the voltage is not 220 VAC the control failed.
Snapshot_1.jpg
 

Dwhenry

Premium Member
Joined
Mar 11, 2020
Messages
8
Location
Karthaus Pa
Thanks for the reply, I’ll pull it out and follow what you said to do. So the replacement part that says it’s compatible, isn't? Are you telling me my oven is (omg) dead? Why would the small side oven have quit?
 

Dwhenry

Premium Member
Joined
Mar 11, 2020
Messages
8
Location
Karthaus Pa
The problem is most likely the ERC and unfortunately it's been discontinued and is no longer available. Access the ERC (clock). Select bake and start. Measure the voltage across E1 (L1) and E7 (BA). If the voltage is not 220 VAC the control failed.
View attachment 48697
Thought I died and went to heaven when I found it on ebay for ~$200. I googled and ordered frigidaire 318010102. They sent 316207522. Is there some way to make this work or do I have to send it back?
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,941
Location
Murray, Utah 84107, United States
They're two totally different controls. Unfortunately they're not interchangeable. We have seen nothing but problems with eBay and Amazon when it comes to appliance parts. For some people it's taken three or four tries before they get a working part. One member had to return three motors before he got one to work. I guess it depends on who is minding the store. Probably not appliance people. Yours wasn't available so they sent you one that was available. I hope you don't have any problems returning it.
 

Dwhenry

Premium Member
Joined
Mar 11, 2020
Messages
8
Location
Karthaus Pa
Has the fun started yet? Returning it won’t be a problem. I actually talked to ebay before I ordered it. Have you an opinion on getting this thing repaired?
 

Dwhenry

Premium Member
Joined
Mar 11, 2020
Messages
8
Location
Karthaus Pa
Yes , it failed. The clock is very dimm, barely readable and when I did what you said , measure the voltage across E1 and E7, there was no voltage and it kept kicking bake off.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
37,941
Location
Murray, Utah 84107, United States
The way I see it is you have three choices; 1st, You can keep looking for a new/used board online. Keep in mind when you buy used appliance electronics, you're usually buying someone else's problems. 2nd, you can send it out to places that repair boards. Here's one such place: corecentricsolutions.com or 3rd, you can replace the range.
 

Dwhenry

Premium Member
Joined
Mar 11, 2020
Messages
8
Location
Karthaus Pa
Saga continues! I found Frigidaire part 318010102 on GeniuneReplacementparts.com and they sent the same damn part that ebay did! Electrolux 316207522! I don’t get it! and I‘m ready to pull my hair out! The picture on their website matched the part I need, not the one they sent. Grrrrrr! What am I doing wrong?
 
Top