970-437136 Kenmore Pro Dual wall oven temp dials not reading temperature

mdevincenzo

Premium Member
Joined
Jul 2, 2018
Messages
3
Location
London, Ontario
Model Number
970-437136
Brand
Sears Kenmore
Age
6-10 years
I was having issues with the lower oven burning food and discover that the broil element was always on when the I turned the oven on. It did not shut off when it reached temperature. I exposed the control board and the relay board hoping to find a fused contact on the broil relay. I found nothing, after I turned the power back on it started to work normally and the oven reached the proper set temperature, but it did not display the temperature on the circular analog temp display. I had and external thermocouple in the oven and that's why I know it was working. I check all the connection on the control board, specifically the temp read out connectors and they all seem fine. Both ovens work fine, but neither displays the temperature. Any idea what is happening?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
100,633
Location
McMullen Valley, Arizona
Hi,

On Canadian Kenmore models we can't lookup the parts diagram here in the USA.

But from the description of the problem it sounds like that clock/oven mechanism went out. Usually the USA Kenmore models have all digital displays, I'm surprised you mentioned yours is a analog display.

Jake
 

mdevincenzo

Premium Member
Joined
Jul 2, 2018
Messages
3
Location
London, Ontario
I have the block diagram of the oven and it shows 2 thermometer connection to P14 and P15 on the oven control board the dwg number is 318416204 REV:A but I don't see a part number on the dwg. Unfortunately the Service Data Sheet that came with the oven doesn't match what I have. Where could I get new OCB for my model?
 

Attachments

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
100,633
Location
McMullen Valley, Arizona
Your Welcome.

Jake
 
Top