• Please note, some of the links on our site are affiliate links (Learn More)

FIXED 970-660130 Kenmore Induction Range Error Code EO 37 but the issue does not seem to be the generator board

Status
Not open for further replies.

DisasterDan

Premium Member
Joined
Dec 22, 2020
Messages
4
Location
Missinipe, Saskatchewan
Model Number
970-660130
Brand
Sears Kenmore
Age
6-10 years
Good Day Everyone, I have a Kenmore Elite 970-660130 Induction Range. It initially started acting up about two months ago with error code E037 while using the induction cooktop or the oven. I tracked down the issue to a left induction generator (part# 316304300) and replaced it. The induction cooktop then worked great but could not get the oven to run. I check the resistance on both oven elements and the heat probe, and both worked. I then replaced the oven control board (part# 316577099). I am now getting error code E037 again when I try to use either the cooktop or the oven. I have tried switching the two induction generators to see if I could isolate the issue, but it resulted in the same error code.

At this point I am flummoxed. I am suspecting that it is a wiring issue but would like some thoughts on what I should be checking next. I am under a bit of pressure to get this range fixed.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,755
Location
Murray, Utah 84107, United States
I'm unable to find any information on that model. Can you recheck the model number. Nothing comes up with that one. It's possible it's because of the area you're in.
 

DisasterDan

Premium Member
Joined
Dec 22, 2020
Messages
4
Location
Missinipe, Saskatchewan
Here's a photo of the model number. I also found a service data sheet that seems to correspond to the range.
 

Attachments

  • Kenmore Range 970-660130.jpg
    Kenmore Range 970-660130.jpg
    323.5 KB · Views: 66
  • 970-660130.pdf
    1.8 MB · Views: 88

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,755
Location
Murray, Utah 84107, United States
It must be the area you're in. Some models not made for the US, we can't get any information on, and that appears to be one of them. Thanks for posting the tech sheet. I'll take a look at it. Is the tech sheet for your model?
 

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
4,259
Location
Ontario, Canada
I looked up the tech sheet that is listed in the parts list and came up with this one:

LINK > Tech Sheet 316905060 (PDF)

For a fault 37 it says:
Tech sheet # 316905060 said:
Error Code: 37
Likely Cause or Failure Condition: Heat sink temp sensor break (left cook zones)
Suggested Corrective Action: 1. Replace left side cook zones generator board.

You said you already replaced the generator board # 316304300.

Maybe check the wiring to the Heat Sink Temp Sensor mentioned in the error message?? I see a part # 316303900 "Sensor Assembly, temperature, X21 to sensors, heat sinks, w/harness" listed. I don't know what it does.

I doubt I can suggest anything else. Hopefully Rick can.


Dan O.
 
Last edited:

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
43,755
Location
Murray, Utah 84107, United States
Check the thermal cutout between the heat sinks. This is from a similar model so should be the same:

PHB925 Cooktop.jpg
 

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
4,259
Location
Ontario, Canada
DisasterDan said:
I have a Kenmore Elite 970-660130 Induction Range. It initially started acting up about two months ago with error code E037

How did you make out with this? You never posted further. It's always nice to hear the outcome. Others that happen by this message might be interested in knowing too.

Dan O.
 

DisasterDan

Premium Member
Joined
Dec 22, 2020
Messages
4
Location
Missinipe, Saskatchewan
I had a couple renovation jobs come up including a kitchen remodel and a basement flooring install that I had to attend to. I am hoping that I will be able to get back to the range in the next week as I wrap up those other projects. Sorry for not responding on this thread for the past three weeks. I will post an update once I get back to the range.
 
Status
Not open for further replies.
Top