FIXED Amana ARB2217CW (PARB2217CW1) Not Cooling

Ponchoguy

Premium Member
Joined
Oct 11, 2015
Messages
162
Location
USA
Model Number
ARB2217CW
Brand
Amana
Age
More than 10 years
Jake:

I came up to visit my sister today and was informed that the fridge is not cooling. Items in the freezer are not freezing and items in the fridge do not seem as cold as they should. I do hear the fan running at the lower rear of the machine. I feel a very slight bit of cold air coming out of the fridge air vents, but I do not hear (and my sister doesn't other) hear any compressor cycling.

I did notice that the coils were packed with dust (small dog lives in the house, sheds minimally), so I vacuumed them clean and will go to Home Depot for a coil brush in a few minutes. What should I check? I'm thinking of pulling out the compressor start relay and seeing if it jiggles (broken pieces) and if so, we know that is the problem (you guys helped me with another machine where this was the problem).

Would a bad compressor relay cause you to have the fan run but not have any cooling? I would think this is a possibility. If you could give me some ideas of what to check that would be great.

Thanks as always.
 

Ponchoguy

Premium Member
Joined
Oct 11, 2015
Messages
162
Location
USA
Update---I took the overload relay off and it's in pieces inside. LOL. So, tomorrow morning, I will be searching for one WLP Part #WP12555902 here in Northwestern NJ.....will update all on the progress.

Thanks.
 

Ponchoguy

Premium Member
Joined
Oct 11, 2015
Messages
162
Location
USA
Yes, I saw that, and if they are open tomorrow (it's President's Day), and no one else locally has it (or is open), then it's to them to grab it.

Thanks.
 

Ponchoguy

Premium Member
Joined
Oct 11, 2015
Messages
162
Location
USA
Installed the combination overload kit and capacitor, WLP Part#W10613606, from a local parts place that had an OEM original. Installed and started back up. We shall see.....thanks.
 
Last edited:

Ponchoguy

Premium Member
Joined
Oct 11, 2015
Messages
162
Location
USA
So far, so good. My sister reports that the machine is working as it should and cycling periodically as it was previously. I think we're good to go for now. Thanks to all, as always.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,849
Location
McMullen Valley, Arizona
Sounds good Poncho, glad to hear that.:)

Thanks for the update!

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,849
Location
McMullen Valley, Arizona
You Bet Poncho.:)

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,849
Location
McMullen Valley, Arizona
Jeff and Rick and bigbuck and Dan O. and Jack are the best too.:)

Jake
 
Top