Amana SBDT 520 JW not defrosting not cold in Fridge

dopel

Premium Member
Joined
Sep 24, 2005
Messages
3
Location
Queensland
I have the above model and have recently replaced the defrost thermostat, which is the one with the orange and Brown wire, though there is another with two blue wires.

My problem is that is was not defrosting, having a excess build up of frost on the coils, would shut the water off due to it being frozen inside the pipes.

Also it would melt all the ice in the icebox and the Fridge unit would not stay cold or get cold

I replaced the defrost thermostat Part R016 1080, and it worked fine for a day with the fridge getting nice and cold as well as the freezer. Though today has returned to frost on front of the coil panel, as well the fridge and freezer not staying cold.

What should I be looking for...... is the other sensor Part R016 1085 with the two blue wires, a heater problem, timer or other

Thanks for your help
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,796
Location
Ontario, Canada
Hi,

it worked fine for a day with the fridge getting nice and cold as well as the freezer. Though today has returned to frost on front of the coil panel, as well the fridge and freezer not staying cold
One day is normally too quick for a frost build up to occur. The coils where completly covered with frost?

I replaced the defrost thermostat
If the defrost heater works ok, we normally replace the deforst thermostat and defrost timer at the same time = less problems.

jeff.
 

dopel

Premium Member
Joined
Sep 24, 2005
Messages
3
Location
Queensland
One day to quick

Jeff, yes I definately thought so, it just shuts down the cooling to the fridge and freezer, defrosted it again witht the heat gun... and fan come on and working fine..... for now.

Have not tested the heater.... though I most likely would say from all of the info etc on here and your suggestion it is the defrost timer.....

,.............. only problem is that I can not find it.... where is it on these models usually


Cheers
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,796
Location
Ontario, Canada
Defrost timer should be behind the front grill at the front bottom.... #28

Kit defrost timer

jeff.
 

dopel

Premium Member
Joined
Sep 24, 2005
Messages
3
Location
Queensland
Jeff,

Thanks for the info... tested the old defrost timer and it is fine, though have replaced it with a new one. Over the weekend we went away, come back to a highly ice packed, coils not temp in fridge, melted ice maker, and refrozen water on the bottom of the freezer, the heater was working, though now, is not, would it be a bad connection from the thermostate or bad heater.

Cheers
 

jeff1

Appliance Tech - Moderator
Staff member
Joined
Oct 10, 2004
Messages
23,796
Location
Ontario, Canada
would it be a bad connection from the thermostate or bad heater.
Very possible....or a bad defrost thermostat which can/will be intermittant. The heater normally works or doesn't work.

jeff.
 
Top