• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Another Whirlpool Gold fridge with problems

heymanisth

Premium Member
Joined
Apr 19, 2011
Messages
3
Location
Calgary
Model Number
GS2SHEXNQ00
Brand
Whirlpool
Age
6-10 years
Whirlpool Gold Conquest side by side freezer fridge manufactured in Nov 2004. It has worked perfectly until this morning when we woke up to a floor full of water. No cold air in the fridge and freezer, the fans, lights, controls all seem to work as before but the compressor does not seem to be working, There is no clicking, hum or any noise or vibration from the compressor and it is not warm. I just replaced the capacitor and relay which is attached to the compressor motor hoping that was the problem, I was wrong.

No frost on any of the coils which are clean and free of lint, I do not have the clicking noises from the compressor.

Just checked for voltage at connector going to the compressor relay, no voltage so at least the compressor isn't the problem (should have done that before buying the non returnable replacement relay and capacitor).

So now I am thinking the circuit board or the t-stat. I removed the board which is next to the compressor to look for burn marks, nothing was found. How should I go about troubleshooting this without blindly replacing parts.
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
111,866
Location
McMullen Valley, Arizona
I don't have the wiring diagram for this model, you should have it, its located behind the bottom kickplate grille in the front below your doors.

Are the inside refrigerator and freezer lights on when you open both doors? Do you hear the freezer fan running in the freezer?

It could be the temp. setting control assembly or the control board in back, but I don't know which without a wiring diagram.

Its a complete assembly you can order here:
Manufacturer's Number: 2255233

2255233


Here's the control board for your model you can order here:
Main Control Board W10135090 Order now for same day shipping. 365 day return policy. RepairClinic.com


Jake
 

heymanisth

Premium Member
Joined
Apr 19, 2011
Messages
3
Location
Calgary
All the lights are on, everything works including the water and the ice machine also if it was cold enough to make ice. yes the freezer fan is also running.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
111,866
Location
McMullen Valley, Arizona
Ok, then the problem is that control board I posted above.

Jake
 

heymanisth

Premium Member
Joined
Apr 19, 2011
Messages
3
Location
Calgary
I replaced the control board and all is good again. Your price is much better than what I paid the local supplier but it had to be fixed today because the Wife was threatening to buy a new more expensive refrigerator if it wasn't running by tonight.
Thanks for the confirmation on the board.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
111,866
Location
McMullen Valley, Arizona
Ok, thats fine, glad the new control board fixed it.:)

Jake
 
Top