• Please note, some of the links on our site are affiliate links (Learn More)

B20CS51SNS/02 Bosch refrigerator not defrosting

Austin1977

Premium Member
Joined
Jan 2, 2020
Messages
3
Location
Montrose CO
Model Number
B20CS51SNS/02
Brand
Bosch
Age
1-5 years
I have a bosch B20CS51SNS /02. It is not defrosting. I has pulled cover panels off the back. It was full of ice side to side 3/4 of the way up. Fan is working, there are 2 sensors attached to the evaporator, the lower one is reading 0 ohm resistance, the one attached to the upper portion reads just under 14 k ohms, the heating element itself gives about 71 ohms resistance. Does all of this sound normal? Curious what voltage should be coming from control board to the element. Only reading 3 vac there, but not sure if this is even going to attempt turning on with the fan and cover panels currently removed?
 

Austin1977

Premium Member
Joined
Jan 2, 2020
Messages
3
Location
Montrose CO
Also, not sure of this is problem related, but there is a periodic clicking that occurs that I do not remember hearing on a consistent basis in the past.
 

Austin1977

Premium Member
Joined
Jan 2, 2020
Messages
3
Location
Montrose CO
Also, not sure of this is problem related, but there is a periodic clicking that occurs that I do not remember hearing on a consistent basis in the past.
Update, after further evaluation, this clicking just seems to be the compressor relay engagement at the back of the fridge. I must just not have noticed it in the past. Still trying to determine the root cause of the inoperative defrost cycle.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,340
Location
McMullen Valley, Arizona
If the entire evaporator was frosted over the problem is defrost related. If only a portion of the evaporator had thick frost and the rest were clear, the problem could be system related. Take a photo of it and upload it here.

Look at these photos below.

Frost Patterns.jpg
 
Top