• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Bosch Dishwasher SHX7ER55UC/50 no lights on control board

the.dish.king

Premium Member
Joined
Feb 4, 2021
Messages
23
Location
Caledonia, ON
Model Number
SHX7ER55UC/50
Brand
Bosch
Age
6-10 years
So I have a Bosch dishwasher that has no lights on the control board. More than that, the dishwasher doesn't do its startup noises that happen when the power button is pressed. The beauty is, I have another unit I have used to test, so I know a lot of the parts are good:
  1. Power board works on the test unit (test unit lights up and starts cycle)
  2. Control board works on the test unit (lights up)
  3. Power switch works on the test unit
  4. Door latch works on test unit

I also have tested continuity on the power cord (brown) and it has continuity to the board (and while plugged in has full 120V - my hand can testify!). Overall the wire harness looks okay. When I test for voltage at the control board between power button presses, it doesn't get as high as it does on the test unit, so it's definitely not the control board's fault!

My question is - could something else be blocking the dishwasher from starting at all? What else could it be other than the parts listed? This is a real conundrum!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,692
Location
McMullen Valley, Arizona

the.dish.king

Premium Member
Joined
Feb 4, 2021
Messages
23
Location
Caledonia, ON
Thanks Jake. There is no error code, since there are no lights whatsoever.

I ended up getting it going, though. I took the pertinent wires off the wire harness of the test unit (power switch wire & control board) and hooked it up to the boards. It worked! Must have been simply a connection issue, although I did test continuity on all of those dang wires.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
125,692
Location
McMullen Valley, Arizona
Ok sounds good.(y)

Thanks for the update!

Jake
 
Top