• Please note, some of the links on our site are affiliate links (Learn More)

Broiler issue Whirlpool gas Range WFG535S0LS

Conestoga

Premium Member
Joined
Nov 3, 2022
Messages
3
Location
USA
Model Number
WFG535S0LS
Brand
Whirlpool
Age
Less than 1 year
Hi all,
New to this forum. I have a whirlpool gas range, WFG535S0LS, that is 2 months old. Broiler lights has small flame and will not broil unless it is within 3/4' of
the broiler tube. All else works fine, bake and top burners. Being under warranty i called Whirlpool, sent out their tech. The first time he could find no issue even though
the flame is small, but he ordered new orifice. Returned 2 weeks later and installed and had same results. He contacted tech support and decided to replace the gas valve,
tube to broiler, broiler tube and electrode for spark. No real difference. All voltages and ohms checkout on the board which I measured after he left according to a
Whirlpool flow chart and schematics for this range. There are no error codes showing. I also can't find what the gas pressure is supposed to be at the broiler out side
on the gas valve it seems to not be high enough. Gas pressure coming into house is fine, am set up for more than enough to run hot water, dryer and range
and have done so for 20 years. Have 1/2' lines to all from 3/4' header.

Using the oven rack in it's top level broils nothing and takes forever to cook temp barely reaches 325* (used multiple thermometers that are accurate).
I am not able to find what the output is for either bake or broil tubes any where.
This was converted to LP. I have owned gas ranges all my life and have never seen a flame this small.
Am not unfamiliar with appliances, gas or electric as having been some years in the field. If anyone has a pic of what this flame is supposed to look like and any
help would be greatly appreciated.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,824
Location
Vicksburg Junction, Arizona

Conestoga

Premium Member
Joined
Nov 3, 2022
Messages
3
Location
USA
This was done originally and replacement ordered was same. I have changed out many of these prior. Also made sure to flip cap on gas valve. Is definitely .090.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,824
Location
Vicksburg Junction, Arizona
Sorry, I don't know then, this is very odd, hopefully another tech. that has seen this issue can shed some light on it for us.

Other than that>ITS BEST You contact Whirlpool back at 1-866-698-2538 and have a tech come out, and if that tech doesn't know either, the tech can call the factory on a special FACTORY HOTLINE tech number from your house, and the factory can get involved in investigating.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,824
Location
Vicksburg Junction, Arizona
Anytime!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top