• Please note, some of the links on our site are affiliate links (Learn More)

Cannot fix F8E0 error on Jenn Air Jgrp430wp01 after replacing motherboard and fan.


Premium Member
Jul 15, 2023
Model Number
More than 10 years
Hi there, and HELP!! I have a Jenn-Air oven range that recently displayed the infamous “F8E0 Low Fan Speed Underspeed”, and I called Jenn-Air and they sent out a tech. He said my Control Board was possibly fried, and that had to be fixed before attending to the fan. Said he needed to replace that first. Instead of waiting the 6-8 weeks for his ordered part, I got one and installed myself. Easy, no problem, except that was not the issue which I predicted. Then he said now that is fixed we can order a new fan. So, I did that myself as well and hoped for the best. I then turned on to bake, and the the blower was working great, I could feel the air being blown thru with ease. Unfortunately, the error came on again to my disappointment. There is no obscruction in the vent, new board, new fan, but same old error code. Could the error code come on if the Oven Temperature Sensor needs to be replaced? I ask this because I can get the bake to go on for a bit until it gets to the desired temperature, and then the code comes on. I really don’t know what to do at this point. And all the posts that I have read here have not helped. I troubleshooted as suggested with reset, and still no results. Anyone have an idea for me? Thanks so much!!


  • 6787830A-5356-4C73-B964-71E0BBE3667F.jpeg
    252.8 KB · Views: 28
  • E4312111-F431-4868-8FA9-DA58562AA508.jpeg
    401.5 KB · Views: 28
So back to this problem. Appliance tech came out after letting him know that nothing has worked so far. He went into diagnostics and tested both fans without any errors coming up in the diagnostic mode. However, still comes up when baking. I did find some other post that you can go into the system info, then more info, and you can scroll to the upper and lower fan rpm. It all says 0. Does that mean there should have been a reading of the test of how many RPMs it was running? And if so, the fan runs fantastic as stated above but in system info it is reading 0. So, I am back to where I started in not knowing what to do at this point. ANyone out there have any ideas?? Thnx in advance.
I'm afraid I have had no training on such a model. I do not know what the reading should be nor how it is achieved. There are some mentions of a "hall sensor" however I don't know if it is a separate component or part of the fan motor. The only sensor listed in the parts list is a temperature sensor.

LINK > JGRP430WP01 Blower Fan

**(I did see one reference that says the above motor includes the hall sensor.)

There is some discussion of that error on some Whirlpool models in the previous form message linked below. Your model was also made by Whirlpool.

Dan O.
Last edited:
  • Like
Reactions: Hak
Thanks Dan. I might need to take the fan out again and check the hall sensor even though it is a new fan. However, I think I am off to Home Depot to get a new range:(

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.