• Please note, some of the links on our site are affiliate links (Learn More)

Can't access diagnostic mode...

CKrypto

Premium Member
Joined
Jan 23, 2014
Messages
11
Location
Florida
Model Number
WRF560SEYM00
Brand
Whirlpool
Age
1-5 years
So, I am trying to troubleshoot a frost problem in my freezer by accessing the diagnostic mode to determine if the issue lies in the defrost element or in the thermistor. The problem is that no matter how many different ways I try, the unit will not go into the diagnostic mode as described in the service notes. I was just wondering if I am doing it incorrectly, or if there somethings that I have to do before holding down the buttons on the front panel. Also, if I am doing it correctly and it is still not working, would that be indicative of a malfunctioning control board? I had recently replaced the control board after a power surge made it so the unit wouldn't even turn on. Just looking for some opinions before I go out and start buying replacement parts. Pic below is from the service notes for reference. Thanks!!

ZjTuuhB.jpg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
Is this the control board you replaced: WPW10336511 Electronic Control Board

If you are following the tech data sheet steps to get it into the diagnotics and its not going into it then what happens when you try? Are the buttons responding at all when you press them?

Jake
 

CKrypto

Premium Member
Joined
Jan 23, 2014
Messages
11
Location
Florida
Is this the control board you replaced: WPW10336511 Electronic Control Board

Yes, that is the part that I replaced about 6 months ago.

If you are following the tech data sheet steps to get it into the diagnostics and its not going into it then what happens when you try?

I hold the buttons for 3+ seconds and nothing at all happens, then there is a single beep when I release the buttons and then nothing. I've tried combinations of buttons including holding SW3 and SW1 and still nothing happens.

Are the buttons responding at all when you press them?

All of the buttons appear to function correctly when pushed for their intended purpose.

Thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
121,755
Location
McMullen Valley, Arizona
When you order parts from AppliancePartsPros or RepairClinic, you have 365 days warranty and 365 days to return any part for a full refund, less shipping, for any reason period! Even if you installed it!

I'd return it for another one under warranty.

Jake
 
Top