• Please note, some of the links on our site are affiliate links (Learn More)

FIXED DDT595SSJ5SS GE Dishwasher Unresponsive

MythrilCuir

Premium Member
Joined
Oct 15, 2022
Messages
3
Location
Chicago
Model Number
DDT595SSJ5SS
Brand
GE
Age
1-5 years
Hi there,

For almost a year now my dishwasher would periodically beep like when the door was being opened. It was annoying, but it still worked. A few months ago it would sometimes be unresponsive to button presses, but cycling the circuit breaker would bring it back to life. This afternoon the breaker trick no longer worked. I managed to get access to the control board and the LED is blinking rapidly, which from what I can tell for this board means it is working properly. I'm really hoping it's not the UI board that needs replacing because from what I've seen it's laborious.

Thank you for your help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,973
Location
Vicksburg Junction, Arizona
Hi,

This thread is how I helped another member fix his:

If the door wire harness is good. Then its the UI Board that is the culprit, since the machine control board(underneath the dishwasher) is blinking.

Here's the user interface(UI) Board for your model: WD21X31910

Remember--->You have to set the personality jumpers on the new UI Board before you install it or it will not work, the instructions that came with the new UI Board show you how to do it.:)

This video gives you the general idea of how to replace it:


Jake
 

MythrilCuir

Premium Member
Joined
Oct 15, 2022
Messages
3
Location
Chicago
Hello again! Thank you for your help. It took me some time to get a multimeter and get the door off, but I did it! I tested the wire continuity from the two sides of the wire harness and it read roughly 0.8 ohms for each wire.

There are some black marks on the connectors on both sides of the wire harness, but nothing on the pins they plug into.


PXL_20221020_232646952.jpg
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,973
Location
Vicksburg Junction, Arizona
Yes, I see that, that's probably just black production markings. It doesn't look burnt.

So the problem seems its the UI Board.

Jake
 

MythrilCuir

Premium Member
Joined
Oct 15, 2022
Messages
3
Location
Chicago
Just posting for anyone who comes across this thread - this worked! The door disassembly was slightly different from the video but wasn't any more challenging.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
135,973
Location
Vicksburg Junction, Arizona
Excellent, glad to hear the new UI Board fixed it.(y)

Thanks for the update!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top