• Please note, some of the links on our site are affiliate links (Learn More)

FIXED Dishwasher issue, smell of burning rubber. Model # WDF320PADW3 Serial # F63820381 Does anyone know if this is belt driven that can be replaced ?

Irishgirl

Premium Member
Joined
Feb 9, 2022
Messages
3
Location
Edison NJ
Model Number
WDF320PADW3
Brand
Whirlpool
Age
1-5 years
Dishwasher issue, smell of burning rubber. Model # WDF320PADW3 Serial # F63820381 Does anyone know if this is belt driven ? Someone told me that if it is then maybe that needs replacing ? It had been working fine and the other day when I put the dishwasher on it smelled like rubber burning. I checked filter, it was clean. I am not in a position to be able to pull this out to look at it. I would need help. Is this model belt driven ?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,229
Location
Redmond, Oregon
Hi,

No, its not belt driven. That is odd about the burnt rubber smell, check to see if something rubber fell on the heating element inside the tub.

Here's the parts diagram for your model:

Jake
 

Irishgirl

Premium Member
Joined
Feb 9, 2022
Messages
3
Location
Edison NJ
Thank you so much !. I am going to see if someone can check the out. Nothing is stuck, filter is clean. I don't know what it is but I will definately post the rest of this story when I get an answer. Thank you again for the answer, and diagram. Have a wonderful day Jake.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,229
Location
Redmond, Oregon
Thanks, you too!

Jake
 

awarren82

Premium Member
Joined
Apr 20, 2017
Messages
16
Location
malvern
Thank you so much !. I am going to see if someone can check the out. Nothing is stuck, filter is clean. I don't know what it is but I will definately post the rest of this story when I get an answer. Thank you again for the answer, and diagram. Have a wonderful day Jake.
How did this end? I have same issue on brand new Bosch dishwasher
 

Irishgirl

Premium Member
Joined
Feb 9, 2022
Messages
3
Location
Edison NJ
It turned out to be the power plug. The plastic had melted and fused everything together. I never would have found it by looking but as soon as the technician pulled it out, there is was. New plug, all fixed. Thank you so much.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
134,229
Location
Redmond, Oregon
Excellent, glad that's all it was.(y)

Thanks for the update!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top