• Please note, some of the links on our site are affiliate links (Learn More)

FIXED DLG2526W LG Dryer No heat

Surf579

Premium Member
Joined
Mar 24, 2014
Messages
75
Location
New York
Model Number
DLG2526W
Brand
LG
Age
6-10 years
No heat. Runs. The button is in on thermal fuse. I test with ohms reader but on sound it beeps Is that good. What else can I check.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,820
Location
McMullen Valley, Arizona
Ok,

The high-limit thermostat with the reset button on it(part number 6931EL3003C) is good if your meter beeped in the ohm setting.

Now ohm test the burner tube thermostat and the blower thermostat.

Here's the burner tube thermostat for your model:
6931EL3004B Burner Tube Thermostat


Here's the blower thermostat for your model:
Thermostat 6931EL3002M


Jake
 

Surf579

Premium Member
Joined
Mar 24, 2014
Messages
75
Location
New York
Ok I checked the other sencer on the opposite side of the thermal one it beeps as well On the exurst that blows out to the vent ther is a plug as well I checked that as well and it beeped I tried to hook everything up while parts where off put would not go , is there a cut off in the pulley? Anyway what is next and is the the 3 seniors you said to check Thank you Jake
 

Surf579

Premium Member
Joined
Mar 24, 2014
Messages
75
Location
New York
Ok I checked the other sencer on the opposite side of the thermal one it beeps as well On the exurst that blows out to the vent ther is a plug as well I checked that as well and it beeped I tried to hook everything up while parts where off put would not go , is there a cut off in the pulley? Anyway what is next and is the the 3 seniors you said to check Thank you Jake

8A2353EA-467B-4AA0-811D-961971B06A23.jpg
 

Surf579

Premium Member
Joined
Mar 24, 2014
Messages
75
Location
New York
I also checked thermistor assembly,it’s next to the thermostat that I circled. It has a red wire with a white plug , with the ohms reader it did not beep but it said 2.211. Dam why so hard to find the headache lol
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,820
Location
McMullen Valley, Arizona

Surf579

Premium Member
Joined
Mar 24, 2014
Messages
75
Location
New York
Well I’m hoping I tested right. I put it on beep the ohms and it did not move or make a sound I cant get the dam thing off it is tight as hell and in a messed up spot lol . So what is you take on it. If I had on beep it still should of registered something. Right? If there suppose to be continuity
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,820
Location
McMullen Valley, Arizona
Ok, then your igniter is bad and that's the cause of the no heat.:)

Jake
 

Surf579

Premium Member
Joined
Mar 24, 2014
Messages
75
Location
New York
Yea, I will see what happens when I get it so that will stop the gas from coming out the valve
As well because I didn’t smell gas at all. soon after I put back and try I’ll send you a update Thank you Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,820
Location
McMullen Valley, Arizona
Correct, if the igniter won't come on, the gas will never start flowing out.

The new igniter should fix it.

Jake
 

Surf579

Premium Member
Joined
Mar 24, 2014
Messages
75
Location
New York
Igniter was no good change it and as working find. All the test that you had me do helped a lot. Thank you jake.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,820
Location
McMullen Valley, Arizona
Excellent Surf, glad to hear the new igniter fixed it. (y)

Thanks for the update!

Jake
 
Top