FIXED DMT400RHW Samsung Dishwasher only "Smart Auto" blinking

Fitz2180

Premium Member
Joined
Jan 30, 2017
Messages
3
Location
Michigan
Model Number
DMT400
Brand
Samsung
Age
1-5 years
My personal dishwasher is having an issue. When I start it, I can here the drain pump start. Then, I hear 4 beeps and the "Smart Auto" light begins to flash. Then the drain pump starts and stops repeatedly...

I checked all the passageways in the water supply line and had no obstructions. I checked to see if I was getting 120v to the water supply valve and have no voltage present.

Can anyone give me an idea of what to look for next. I fear that it may be the main board, but am hoping that it is just a sensor.

Thank you!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,166
Location
McMullen Valley, Arizona
Hi,

I posted the service manual for this model in post #2 here: Samsung DW Error Code Heavy + Smart Auto

Look at Page 39: Blinking "Smart Auto"=Water Supply Error

Possible defect: Main board, Water supply valve, flowmeter.

Since your not getting 120 volts to the water supply valve, then it would be the Main board.

Here's the Main board for your model you can order:
Samsung DE92-02256C Assy Pcb Main


Here's another member that found the same, was the main board: FIXED Samsung dishwasher DMT300 -- No water

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,166
Location
McMullen Valley, Arizona
Sounds good, let us know how it goes!

Jake
 

Fitz2180

Premium Member
Joined
Jan 30, 2017
Messages
3
Location
Michigan
Okay, my board arrived and it was an easy swap. Start her up, anticipating a victory. It did the same thing... No voltage at the water supply valve.

I traced my wires and checked continuity, thinking maybe a break somewhere. Everything checked out good. Just to be sure, I checked the terminal of the circuit board where the brown 120v line wire connects to. No voltage out of the board...

Just for grins, I ran it through the SVS inspection mode, by pressing "Heavy"+"Delicate"+"Power" buttons at the same time. I hit "Normal" once, to go to mode 1 - "Smart Auto". To my surprise, I now had voltage to the valve! I had the water off, so it didn't sense water flow, but I had it there for a few second.

What Sensor is bypassed during the SVS Inspection Mode, to allow 120v to come out of the board and power up the valve?

Thanks!
Mike
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,166
Location
McMullen Valley, Arizona
That's very strange Mike, that should of fixed it.


What Sensor is bypassed during the SVS Inspection Mode, to allow 120v to come out of the board and power up the valve?
I posted the service manual for this model in post #2 here: Samsung DW Error Code Heavy + Smart Auto It will show/tell you.

Jake
 
Joined
Jan 13, 2019
Messages
1
Location
Cleveland
I had the same flashing light. Changing the water inlet valve solved the problem. (About $60). Just make sure you dont kink the drain tube when putting the dishwasher back in place. (You'll get another flashing light, heavy i think, and the tub wont drain).

There is also a real good youtube video on this repair. Took about 1 1/2 hours taking my time. The hardest part was fishing the small rubber tube from the inlet valve to the side water thing to feed the water jets. (Make sure the tube isnt binding on the wiring harness).

Btw. Telescoping magnet comes in handy when you drop a screw down into the washer. Plus a magnetic bowl to hold the screws comes in handy too!

Have fun!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,166
Location
McMullen Valley, Arizona
Top