• Please note, some of the links on our site are affiliate links (Learn More)

FIXED DU1055XTVS8 Whirlpool Dishwasher Quiet Partner II not working

Status
Not open for further replies.

WhirlpoolDish

Premium Member
Joined
Feb 23, 2021
Messages
7
Location
Houston
Model Number
DU1055XTVS8
Brand
Whirlpool
Age
6-10 years
Our dishwasher stopped working 2 months ago. Here is the order of events. Model number is DU1055XTVS8.

1) Normal light blinking. Reset the dishwasher. Ran one cycle but did not drain water.
2) Troubleshooting with removing ribbon at P1 in control board. Drained all the water. So figured there was a problem with the control panel.
3) Replaced the control panel. Worked for a cycle but did not drain water again this time. Reset and drained water. After this none of the buttons on the panel were working (no lights).
4) Next, replaced the thermal fuse. Nothing worked.
5) Replaced the control board too.

Still nothing. Dishwasher does not turn on. None of the buttons work. Now, even removing the ribbon at P1 in the control board does not drain or do anything.

Please let us know how to fix this issue. Thank you.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Sounds like possibly a bad control panel keypad. Put the old control board back in and do the P1 test again.

Look here:
His model uses the exact same control panel keypad yours does.

Jake
 

WhirlpoolDish

Premium Member
Joined
Feb 23, 2021
Messages
7
Location
Houston
Thank you Jake. As you suggested, I put the old control board back and did the P1 test again. Nothing works. No motor running. What do you suggest we do next? This is the new control board we ordered. Could it have gone bad too?
 

Attachments

  • New Control Board.jpg
    New Control Board.jpg
    75.3 KB · Views: 10

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
$61.91 US DOLLARS for a open box control board that retails at $210 NEW? Buying parts on ebay is not wise, too many people get ripped off there. It would be better just to buy a new dishwasher for $399, then you get all brand new parts with a 1 year warranty on them.:)

Measure the voltage across P2 and P6 on the control. If your meter indicates 120 VAC, replace the control board:
WPW10285180 Electronic Control Board


If you get 0 volts, ohm test the thermal fuse you bought.

Turn your breaker off to your dishwasher first if you haven't already, then remove those two wires to it, then ohm test it.

Thermal Fuse W10258275


Watch this video:


If it is bad, order the new one, and you must replace the wiring that comes with the new thermal fuse kit. Instructions are included!

Jake
 

WhirlpoolDish

Premium Member
Joined
Feb 23, 2021
Messages
7
Location
Houston
Thank you so much Jake. We had our doubts on the control board. I will get back to you after performing the suggested tests. I really appreciate your input. Thank you so much!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Ok, sounds good, yes keep us posted.

Jake
 

WhirlpoolDish

Premium Member
Joined
Feb 23, 2021
Messages
7
Location
Houston
Hi Jake,

We measured the voltage across P2 and P6 and we are getting 124 V. So, from your post above, it appears like the control board needs to be replaced. We will be ordering a new control board today. I will keep you posted. Thank you!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Yup, you nailed it!

Yes, keep us posted when you get the control board installed.:)

Jake
 

WhirlpoolDish

Premium Member
Joined
Feb 23, 2021
Messages
7
Location
Houston
Hi Jake,

Apologies for the delay. So while we are in the process of ordering a new control board, we continued doing a few more tests to determine what is causing this issue. This is because after we did the P2 and P6 voltage test and put everything back in place, the lights came on, the dishwasher wasn't dead anymore :). So we then tested the continuity of door handle switches. It went fine but one of the switches took longer to pass i.e. ~5 secs. We also tested voltage at P4 and P6 to be around 123.x V. Also we heard a clicking sound, of likely relay when power was turned on.

The dishwasher was powering on, We even reset the dishwasher and it started running the normal cycle. Had to hit cancel/drain to stop it. We waited to load up the dishwasher. 2-3 days later, nothing again. Completely dead. There was no power when it was loaded and ready to be run. And now, it is showing zero(0) voltage between P4 & P6.

Does this mean the control boards are fine? No power coming into the board. We checked the voltage at the main junction box yesterday and we are getting a 0 :(. Could there be an electrical/wiring issue? Should we also change door handle switches? Now, we are really not sure what is going on here. I'd appreciate any pointers on how to proceed further. Thank you very much.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona

WhirlpoolDish

Premium Member
Joined
Feb 23, 2021
Messages
7
Location
Houston
Hi Jake, very happy to let you know that our dishwasher is finally working. As I stated earlier, the problem started with flashing lights, not draining, turning on for sometime and then going completely dead. Somewhere in between, the wire plugged into the socket came loose and that is what was causing all these issues. We plugged it back in and now everything seems to be fine. Thank you for guiding us through the issue.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
117,784
Location
McMullen Valley, Arizona
Excellent, glad that was all it was, good find.(y)

Thanks for the update!

Jake
 
Status
Not open for further replies.
Top