• Please note, some of the links on our site are affiliate links (Learn More)

E20 error code - cooktop not working (Kenmore Induction 970C426030)

Ms. J

Member
Joined
Sep 29, 2021
Messages
1
Location
Ontario, Canada
Model Number
970C426030
Brand
Sears Kenmore
Age
1-5 years
We have a Kenmore Elite Slide In Induction Range Model 970C426030 s/n AF41501924 that was showing error code E20. This error code indicates a communication error between the cooktop control board and the wiring harness. Although this model was purchased in Canada, it says that it was distributed in the USA. My parents purchased it approx 5-6 years ago from Sears Canada and gifted it to us when they moved. Although branded Kenmore Elite, the range was made by Electrolux. Sears and Kenmore no longer exist in Canada and I am having trouble finding assistance. (I called a repair company and the technician had only seen two induction stoves before but nothing like ours because there is a flat button panel instead of knobs. He thought we needed a new "power board" which is in stock. If not, then a new cooktop control board which is backordered 12 weeks to indefinitely. Nothing about this tech gave me confidence in his knowledge and then no one showed up to a scheduled appointment to try installing the power board. They wanted me to wait another 2 weeks to have it rebooked.)

I have attached pics of the model and s/n sticker, the whole inside panel and the cooktop control board. I am hoping someone may have insight into the problem and suggestions about what to check or do next. If I knew it was likely one thing or another, I would try to source and order the parts myself.

The cooktop and oven were working fine. Sometimes a persistent clicking noise would occur (like someone turning a light switch on and off repeatedly) and it did not seem to relate to use of the oven or cooktop, spills or weight of pots on the stove. I was told that the clicking happens with induction units but it was very annoying. It wouldn't stop even after unplugging the unit and plugging it in again or turning off the breaker for a bit. It still happens now a while after using the oven.

I boiled water in a small pot (front left burner) and poured it into a teapot (right side middle), spilling a little of the water. I used a towel to clean it up immediately and no water seemed to get close to the seal at the front where the control panel is located. This may be irrelevant but the error code came up just after this. This was 5 weeks ago.

When touching any button to turn on a cooktop element or lockout, E20 appeared with a beeping noise. It could be cleared by pressing 'Stop' but would happen again when touching cooktop buttons. The clock, timer and oven continue to work fine with no issues.

My father-in-law removed the back cover of the stove and nothing stood out as unusual. He thought he might see some burned wires or a blown fuse.

So, wise appliance techs, any suggestions? I am really hoping to not have to buy a new stove!
Thank you.
 

Attachments

  • IMG-7239.jpg
    IMG-7239.jpg
    377.7 KB · Views: 19
  • IMG-7235.jpg
    IMG-7235.jpg
    326.7 KB · Views: 21
  • IMG-7240.jpg
    IMG-7240.jpg
    345.3 KB · Views: 20
  • IMG-7237.jpg
    IMG-7237.jpg
    351.9 KB · Views: 21
  • IMG-7236.jpg
    IMG-7236.jpg
    413.9 KB · Views: 21
  • IMG-7238.jpg
    IMG-7238.jpg
    418.7 KB · Views: 19
Top