• Please note, some of the links on our site are affiliate links (Learn More)

E30MC75JPS3 Electrolux lower oven broil not coming on.

DThacker

Premium Member
Joined
Jul 2, 2022
Messages
2
Location
West Central Ohio
Model Number
E30MC75JPS3
Brand
Electrolux
Age
6-10 years
Lower oven broiler element not coming on.
I checked the broiler element for resistance, I read 18 Ohms.
I checked the incoming voltage, I get 120v to ground on one wire. 0 V on the other wire to ground.
I checked the heat sensor resistance I get 1080 Ohms.
I checked if power was being passed through relay K2 and it was not but after other trouble shooting and some power cycles then I saw power being passed through k2.
I then checked the leads to the broiler element again and both showed 120v to ground. So I figured the element was bad after all. Ordered and replaced the element but had same results and all tests show I am back to 120 on one lead and 0 on the other.
If I set to bake mode the oven starts to heat up using the lower element the broil element does not come on.

Any thoughts. I am about to pull the unit out from the wall again to test to see if I am getting power from k2 relay but I also don’t know how to tell if the relay is being told to turn on.
So k2 relay bad or controller problem.

Thank you,

D
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
Hi,

You need to test across the broil element terminals, not each to ground.:)

Put one meter probe on the broil element terminal and the other meter probe on the other broil element terminal and you should get 240 volts.

The problem is the relay board:
Board 316570520


Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
132,461
Location
Redmond, Oregon
Ok, that still indicates you need the new relay board to fix it.

Make sure you disconnect power to the oven first!

Jake
 
If you feel that you have benefited from this site, and would like to show your appreciation.
Top