Electrolux EIDW6105 Lights Flashing and Drying Damper Error Light Lit

starzbullies

Premium Member
Joined
Feb 4, 2012
Messages
5
Location
USA
I have an Electrolux EIDW6105 Dishwasher (about three years old). The lights are flashing on the control panel, and the drying damper error light is lit. How can I troubleshoot this problem? Or, where can I find the technical manual for it?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,112
Location
McMullen Valley, Arizona
I couldn't locate a repair manual for it, but did locate the tech. data sheet:
http://manuals.electroluxusa.com/prodinfo_pdf/Kinston/154676603.pdf

Here's the upper vent damper assembly you can order here:
Manufacturer Number 154773401


The drying vent sits on top of the dishwasher in the right rear corner. The dishwasher will need pulled forward to expose it.

Nothing special to replace the damper. Just twists, to remove it. The screws should be on the underside of the counter top.

Jake
 

starzbullies

Premium Member
Joined
Feb 4, 2012
Messages
5
Location
USA
Jake, thanks for getting back to me! I decided to take the dishwasher apart and reseat all of the connectors from the main control board behind the kick plate, reseated the connectors to the control panel, and the one going to the upper damper fan assembly. After that, I ran the relay tests on the tech data sheet and everything seemed to work fine. I then slid the unit back into place and connected the water. I ran three normal washes yesterday, and will continue to test the unit today. It seems to be working fine now. We'll see how long it works. :confused:
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,112
Location
McMullen Valley, Arizona
Ok, thats fine, let us know if the problem pops up again.

Jake
 

starzbullies

Premium Member
Joined
Feb 4, 2012
Messages
5
Location
USA
Well, the dishwasher was working fine up until last week. Same error conditions. I reseated the lower control board connectors (behind the kick plate) last night with no success. I have now reseated the two control panel connectors and will run several test wash cycles. I will give an update later today or tomorrow. I am amazed at how many problems this dishwasher has had. I already had to replace the circulation motor and now this makes the third breakdown of this unit. I'm really disappointed that a unit that cost a good penny can't deliver as well as the builders grade GE it replaced...
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,112
Location
McMullen Valley, Arizona
Yes, I completely understand your disappointment with this dishwasher.

Keep us posted.

Jake
 

starzbullies

Premium Member
Joined
Feb 4, 2012
Messages
5
Location
USA
Update... Reseating all of the connectors on the main control board (behind kickplate) and also the two connectors on the control panel several times did not work. I also held down the high temp button to do a reset several times to no avail. Lastly, sometime over the weekend I am going to AGAIN pull the dishwasher from under the cabinet to reseat the blower/damper. The last time I reseated all the connectors it worked for several months. If that doesn't work, I guess I will try replacing the blower/damper assembly. BTW... when I run the diagnostics, the blower/damper seems to work fine... One thing I do know... Searching the internet for problems with this dishwasher... I AM NOT THE ONLY ONE SEEING PROBLEMS! :mad:
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,112
Location
McMullen Valley, Arizona
Yes, many others have had to change that blower/damper assembly to fix this issue.

Jake
 

starzbullies

Premium Member
Joined
Feb 4, 2012
Messages
5
Location
USA
Another Update... At the end of May, I replaced the the lower control board Manufacturer Number 154750502 (behind the kick plate) and the dishwasher worked great... Until a couple of weeks ago. Now, I have the flashing lights, AGAIN. But now, instead of the drying damper light being lit, I have the Main Control Board light lit. When I get the error condition, I hold down the high temp button to reset the unit. So far, the unit will work after doing this. I turned off the breaker to clear the Main Control Board light. I want to see if the Main Control Board light stays consistent with each failure. BTW... My Electrolux OTR EI30SM55JSC microwave bit the dust this weekend! I'm really glad I spent $6500 for all of these great Electrolux appliances when I decided to replace my BUILDERS GRADE APPLIANCES that didn't look as nice, BUT SURE WORKED RELIABLY. The appliances receive minimal usage as it's only my wife and I. My Electrolux appliances can't even last three years without problems. Wonder how long it will be before the refrigerator and range start having problems? QUALITY PRODUCTS? I DON"T THINK SO! :mad:
 
Top