• Please note, some of the links on our site are affiliate links (Learn More)

EW23BC85KS7 Electrolux fridge condenser fan no power

Bridles

Premium Member
Joined
Aug 18, 2021
Messages
5
Location
canada
Model Number
EW23BC85KS7
Brand
Electrolux
Age
6-10 years
Hi there,
We had a power surge awhile ago that caused the condenser to not run. The lights and panels all worked fine but we lost all cooling in the fridge/freezer. Replaced the inverter box and the compressor worked again! Ran the fridge for a few days and noticed extreme heat between the doors and then discovered that the compressor fan was not running. Tested power to the fan and we didn't have any or enough. I have ordered a power board and waiting for it to arrive, but in the meantime is there an easy way to check the wiring from the power board to the fan plug to make sure nothing was pinched/pulled/broken when the inverter was installed as that was a tough job with not much room.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,803
Location
McMullen Valley, Arizona
Here's the main power control board for your model:
242115275 Board-Main Power


Here's the condenser fan motor for your model:

I have ordered a power board and waiting for it to arrive, but in the meantime is there an easy way to check the wiring from the power board to the fan plug to make sure nothing was pinched/pulled/broken when the inverter was installed as that was a tough job with not much room.
All you can do is check the external wires for a break in them to the condenser fan motor, get a flashlight or droplight and look underneath the refrigerator to see if you notice any breaks in the wiring.

Jake
 

Bridles

Premium Member
Joined
Aug 18, 2021
Messages
5
Location
canada
Hi there,

So we installed the new board. The fan is still not working. tested to wires from new board to where they plug into the fan connector and its 16v. So it seems that there's not enough power coming to the fan? I thought I heard a snap sound when first plugging in the fridge too.. everything else is working fine
Any ideas or could that snap be the demise of the new board?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,803
Location
McMullen Valley, Arizona
Then its likely the main power control board, did you remove the main power control board and look for burnt components on it?

Jake
 

Bridles

Premium Member
Joined
Aug 18, 2021
Messages
5
Location
canada
We replaced the main power board underneath the front of the fridge. Part #242115275.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,803
Location
McMullen Valley, Arizona
That's very strange, then it has to be a broken wire from the power board to that condenser fan motor.

If you are unable to locate it, then its best to have Electrolux come out at 800-265-8352 and they should be able to locate it.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
122,803
Location
McMullen Valley, Arizona
Your welcome, let us know what they find, I'm very curious too.

Jake
 
Top