• Please note, some of the links on our site are affiliate links (Learn More)
  • Important Announcement

    It's with sad news to announce that our site owner, Jake, has passed away. You can read the details here.

F3 error Jenn AIr JDS9860ACP Range


Premium Member
Jun 26, 2010
Model Number
More than 10 years
I am back (unfortunately.)
while I thought I had the various issues with this range sorted a couple of weeks ago, and it seemed to be working well/correctly, last night I got an F3 error.
There are other threads here re: F3 error Jenn AIr, but I am not sure they apply to this specific model.
I tested the sensor and it reads 1083 ohms.
as a Hail Mary I replaced it with a spare that I had (that measured 11xx ohms)
But No, after 40 minutes it failed on an F3 error

is there anything else I can test?

hmmm, interesting. there seem to be two series of Jenn Air error codes: for older ones and for newer models.

which is mine?
Hi Peter, I'm attaching your tech. data sheet below.

F3-1 is a Open or shorted sensor. Disconnect power to the range and also check the wiring to the oven sensor to make sure its good, tight, and secure.

Like I mentioned here:
Yes, if you get 1050 to 1100 ohms, then the oven sensor is good and the problem would be the control board.

Oven Control Board 5760M302-60

RepairClinic ships to Canada: https://www.repairclinic.com/PartDetail/Oven-Control-Board/WP5760M302-60/1534555


  • techsheet-16025923.pdf
    862.1 KB · Views: 23
I'm back.

now this might be getting confusing (it is to me) so let me back up.
Oven #1 failed (on the F3 error)
so I found donor oven #2. (though the donor told me that it had failed, though they could not remember the specifics of the failure. Hey It was free)

I swapped Circuit Board #2 and sensor #2 onto Oven 1.
and I still got the F3 error.
Sensor 2 (now in Oven 1) reads 1091 ohms. which I think is Good

I then found a 3rd same-model donor oven and I swapped in its circuit board #3 into Oven 1 (replacing Circuit Board #2).
after about 40 minutes again, it went F3.

I ohms tested the sensor (that is #2 because I figured I'd swap it) Again and it read 1091. which I think is "Good"

Now interestingly, I then put circuit board #2 (I had removed it to swap in CB#3) into Oven #3 (the one I just got) and fired it up. 90 minutes later it was still ticking along, seeming to work fine.
so weirdly Donor Oven 3 with Sensor 3 but CB2 works correctly.
Oven 1 with Sensor 2 and CB3 fails on F3
and also failed on F3 with Sensor 2 and CB2 (which is now working correctly in donor Oven 3.)

easiest solution would be to (gently) move Oven 3 (working, at least on the driveway test site) into the place of Oven 1 (failed on F3 with replacement Sensor and Circuit Board swapped in)
BUT Oven 3 is pretty "worn", greasy. Oven 1 is pretty clean (and the clickers work finally after swapping in some Oven 2 clicker parts.)

if any of that is unclear please tell me.

does anyone have any ideas at this point?
latest tests

I just set up Oven 1 with Sensor #3 and Circuit Board #3 and it failed on an F3 after about 45 minutes

However Donor Oven 3 with Sensor 2 and Circuit Board 2 (with which Oven 1 failed yesterday) is running fine. NO F3 error.

So to recap.
A: Oven 1 Sensor #2 and Circuit Board #2 = F3 FAIL
B: Oven 1 Sensor #2 and Circuit Board #3 = F3 FAIL
C: Oven 1 Sensor #3 and Circuit Board #3 = F3 FAIL

D: Oven 3 with Sensor #3 and CB #2 = WORKS
E: Oven 2 with Sensor #2 and CB #2 = WORKS

Given A and E there must be something other than Sensor or CB causing the F3 failures,

any more ideas?

( could now just swap out Oven 1 for Oven 3 except that Oven 1 is nice and clean and the burners click ignite and Oven 3 is dirty and I haven't tried the burners at all.)
see that I misreported my findings in my post from June 18 (above)
it should have read:
So to recap.
A: Oven 1 Sensor #2 and Circuit Board #2 = F3 FAIL
B: Oven 1 Sensor #2 and Circuit Board #3 = F3 FAIL
C: Oven 1 Sensor #3 and Circuit Board #3 = F3 FAIL

D: Oven 3 with Sensor #3 and CB #2 = WORKS
E: Oven THREE with Sensor #2 and CB #2 = WORKS
But now, I'm BACK.
It's "The Return of the F# Error"

so, when I left off 45 days ago, I had run the above tests and Since Oven 3 was the only one that worked reliably I swapped it in.
and we have run happily since then (not every day, not every week but 15-20 days) on long cycles of 2 hours + (bread baking)
and tonight, after, as usual abou 40 minutes BANG F3.
WTF. ?

how is that possible?
three of the exact same Jenn AIr unit ALL failing on an F3 (or in the case of Unit 1, F1 - excessive temperature )

are these Jenn AIrs just lemons?

any suggestions on what to do now?

I still have the old Senoor and Circuit Board. and I will swap them in tomorrow and see if that helps anything.

But really, if there was another model of oven with a under floor venting system, I'd be all over it.
and so, today I set the oven on BAKE 250 degrees and it happily ran for over 3 hours.
No F3
Very strange

Users who are viewing this thread

Support Our Site

If you feel that you have benefited from this site, and would like to show your appreciation, please consider making a donation.