• Please note, some of the links on our site are affiliate links (Learn More)

FASE7073LW0 Affinity dryer e61 after replacing control board

JJHunter2686

Premium Member
Joined
Mar 18, 2020
Messages
2
Location
S.C.
Model Number
FASE7073LW0
Brand
Frigidaire
Age
6-10 years
I have a Frigidaire affinity dryer that is giving the e61 code. I thought I had a bad board(the one with the relays inside not the front board with the controls) after testing so I replaced it, but I am still getting an e61 code after running for 5 mins. The dryer is heating and working as it should for that first five minutes. I also replaced the temp sensor by the filter housing with no change. Any help is greatly appreciated.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,958
Location
McMullen Valley, Arizona
Hi,

E61=Heater Relay failure
Heater relay stuck open or closed; Wiring defective
Check for short circuit across heater relay(s) (RL5, RL6, RL7) or L1 applied to heater relay output(s) (J5-2, J7-1, J7-3) with cycle stopped. Check for open circuit between L1 and heater relay connection(s) (J5-1, J5-3, J7-2). If no wiring problems are found, replace Electronic Control Board and retest.

Is this the control board you installed below?

809160802 Control Assembly


Also check your heating element to make sure the coils are not touching.

Here's the heating element for your model below, see the 3 coils.



Jake
 

JJHunter2686

Premium Member
Joined
Mar 18, 2020
Messages
2
Location
S.C.
That is the board I replaced. I did a little more digging and it appears when the coils get hot they are sagging down into one another and or the case. I will be buying a new element today. Thank you
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,958
Location
McMullen Valley, Arizona
Yes, that would cause it, good find!

Let us know how it goes.

Jake
 

HockeyAndrew

Premium Member
Joined
Apr 8, 2020
Messages
2
Location
Northern Virginia
I am having a very similar issue to this minus the sagging coils.
- Frigidaire Affinity FASE7073LW0
- Replaced the Heating Element 3 months ago (after getting an E63 error)

I started getting an E61 error after 3-5 of run time, but heat is definitely working. Replaced the Control Board (picture attached) and instantly got an E93 error when plugging in the power. I was then told to replace the Control Assembly (picture attached) and it changed nothing. Any thoughts Jake?
 

Attachments

  • frigidaire-control-board-137260610-ap4587315_01_m.jpg
    frigidaire-control-board-137260610-ap4587315_01_m.jpg
    30 KB · Views: 40
  • frigidaire-control-assembly-809160802-ap5950034_01_m.jpg
    frigidaire-control-assembly-809160802-ap5950034_01_m.jpg
    29.8 KB · Views: 44

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,958
Location
McMullen Valley, Arizona
Ok,

E93--->Machine configuration checksum error--->Wrong configuration data loaded, Interface Board or Electronic Control Board or wiring defective.

Check if correct Interface Board and console are installed. Replace Interface Board and/or console.

What are the part numbers you installed? Where did you get the parts from?

Here's the user interface for FASE7073LW0:
137260610 Control Board


The main control board I posted in post #2 above.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
112,958
Location
McMullen Valley, Arizona
Ok, then it has to be defective wiring, that's all it can be at this point.

If your wiring checks good, then you will need to set up a service call for Frigidaire to come out.

Jake
 
Top