• Please note, some of the links on our site are affiliate links (Learn More)

FEF366DCA Frigidaire Range - Oven Bake and Broil not working

Lynn2020

Premium Member
Joined
Nov 11, 2020
Messages
2
Location
Oregon
Model Number
FEF366DCA
Brand
Frigidaire
Age
More than 10 years
Oven made a large popping noise and tripped the breaker. Electric stovetop still works, bake and broil doesn’t. I’ve pulled the bake and broil elements and no abnormalities Noted. On the meter they both tested at 20 ohm’s. The power strip tested at 120, 120, 240. Please see attached picture of the control board. On the bottom right hand corner surrounding the black box there is a black material surrounding the region. Could this explain why the oven and broiler or not working? Any recommendations are appreciated. I’m considering replacing the control board, but wanted to get some advice first.

Many thanks!

Corrected Brand
 

Attachments

  • BF235DE0-94A1-4A34-92A5-D35B45EBCAF9.jpeg
    BF235DE0-94A1-4A34-92A5-D35B45EBCAF9.jpeg
    324.9 KB · Views: 31
  • A3658249-BE97-49A8-B29A-28F7B57CBBC4.jpeg
    A3658249-BE97-49A8-B29A-28F7B57CBBC4.jpeg
    293.1 KB · Views: 30

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
3,468
Location
Ontario, Canada
You posted that this range is a Whirlpool but that model number is actually from a Frigidaire.

That PCB doesn't look good, no. If you're getting the full 240 volts to the board but no power out to the oven elements, that scorch could very well be why. In that cause that circuit board would have to be replaced.

LINK > FEF366DCA Electronic Control

There is a core refund available from that supplier. If you return the old part to them, they will credit you $50 for it.


Dan O.
 
Last edited:

Lynn2020

Premium Member
Joined
Nov 11, 2020
Messages
2
Location
Oregon
Thanks for the info! I’ll go ahead and order a new board. Sorry about the mix up concerning the brand.
 

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
3,468
Location
Ontario, Canada
As long as both L1 and L2 are getting to that circuit board and there's no problem in the wiring to the elements, I can't see the problem being anywhere else.

Let us know how you make out.

Dan O.
 
Top