FER300SX/XAA Samsung Electric range - control board clock button

Pursuit5

Member
Joined
Jun 14, 2019
Messages
4
Location
Ohio
Model Number
FER300SX
Brand
Samsung
Age
6-10 years
A few lights out on our clock time. Ordered a control board, once installed all lights up shows 12:00 am, however when pushing the clock button it shows hi or lo with each push. But can set oven. All others seem to work except the clock button? Hope you can help? Thanks.
 

Attachments

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,507
Location
McMullen Valley, Arizona

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,507
Location
McMullen Valley, Arizona
Ok, then I'd order the membrane too.

Jake
 

Pursuit5

Member
Joined
Jun 14, 2019
Messages
4
Location
Ohio
Replaced the switch membrane today and the clock button still isn’t working? It still goes to hi and lo.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,507
Location
McMullen Valley, Arizona
Ok, I don't know what else it could be, those are the only 2 parts that control the buttons.

You'll likely need to have Samsung come out and see what's going on.

Jake
 

Pursuit5

Member
Joined
Jun 14, 2019
Messages
4
Location
Ohio
Yes, after chatting with Samsung, they said it was best to schedule with a technician to come and it would be resolved. Will let you know the outcome.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
103,507
Location
McMullen Valley, Arizona
Ok, sounds good.

Jake
 
Top